summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-07 15:25:48 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-07 16:10:27 +0200
commitcf6edf6a305aa10debb45048dd25b2bcafc74032 (patch)
tree6a534f83c5c411a4430a77efc18673dbee601d88 /dev-python/attrs
parentdev-python/pytools: Bump to 2024.1.12 (diff)
downloadgentoo-cf6edf6a305aa10debb45048dd25b2bcafc74032.tar.gz
gentoo-cf6edf6a305aa10debb45048dd25b2bcafc74032.tar.bz2
gentoo-cf6edf6a305aa10debb45048dd25b2bcafc74032.zip
dev-python/attrs: Bump to 24.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/attrs')
-rw-r--r--dev-python/attrs/Manifest1
-rw-r--r--dev-python/attrs/attrs-24.2.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/attrs/Manifest b/dev-python/attrs/Manifest
index ffea536033ba..b2a3940b7a81 100644
--- a/dev-python/attrs/Manifest
+++ b/dev-python/attrs/Manifest
@@ -1,2 +1,3 @@
DIST attrs-23.2.0.tar.gz 780820 BLAKE2B a06f4f17a81fc173c37661bcf518367a1cdc9a333d2783bd2cd1ac5f0a72bd20ec1afdd964e10255624bcfa027e3a152375cd21472c177428d29bd06b29984a1 SHA512 d8b178072a028b95d8424cd3ce0c8b4e6da8558fbcbcaaef91fbd03cf51e6190aa248aa0bff853e6f7c9595bbd5a8eef9d6f68ae2830cc1cc6d826ab0dda2378
DIST attrs-24.1.0.tar.gz 792572 BLAKE2B ece012327c6fd5de771376dd70a5a739a282c22cf7fe536d943072193dc45cc5efcf492fe40c46e837bd036109ca01073dd10aec6e116efa668af0872cc51a3a SHA512 dd84da9b06f5da2724d834c1b8b3ffb5d745d49c8a168e0503ca7572561b2021562b5bbfeea133a7d097fc9423a05494f372e72a9fcc25ada2f745c34a80fdab
+DIST attrs-24.2.0.tar.gz 792678 BLAKE2B f5110f5bf4b848a929a3766985fc49ee8da346398c26d0f786a12d89e7596ec7165bdefaae4b2716003c4b3ad7fcc619ec2f5e0d184df899318a7bb02c9919a4 SHA512 fcd14ff79a09a0b2b56734c460b5c43836999b6ed27665038ff7a146f53891b31ab3da07df05f1686474507f342bfce09bc0a6a60865c241e58f7ce8423dc968
diff --git a/dev-python/attrs/attrs-24.2.0.ebuild b/dev-python/attrs/attrs-24.2.0.ebuild
new file mode 100644
index 000000000000..d4334e9fcb82
--- /dev/null
+++ b/dev-python/attrs/attrs-24.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Attributes without boilerplate"
+HOMEPAGE="
+ https://github.com/python-attrs/attrs/
+ https://attrs.readthedocs.io/
+ https://pypi.org/project/attrs/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+BDEPEND="
+ >=dev-python/hatch-fancy-pypi-readme-23.2.0[${PYTHON_USEDEP}]
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest