summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-07 15:19:55 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-07 15:19:55 +0300
commit3a5537e5c62f64bf0bc1ccc3edc089431c6a6232 (patch)
tree3964c1e4abc29ca745dbd0c19d36c2d79e1ab30b /dev-python/argparse-manpage/argparse-manpage-1.5-r1.ebuild
parentdev-python/argparse-manpage: patch out six dep (diff)
downloadgentoo-3a5537e5c62f64bf0bc1ccc3edc089431c6a6232.tar.gz
gentoo-3a5537e5c62f64bf0bc1ccc3edc089431c6a6232.tar.bz2
gentoo-3a5537e5c62f64bf0bc1ccc3edc089431c6a6232.zip
dev-python/argparse-manpage: rev bump
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/argparse-manpage/argparse-manpage-1.5-r1.ebuild')
-rw-r--r--dev-python/argparse-manpage/argparse-manpage-1.5-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/argparse-manpage/argparse-manpage-1.5-r1.ebuild b/dev-python/argparse-manpage/argparse-manpage-1.5-r1.ebuild
new file mode 100644
index 000000000000..749cf5783462
--- /dev/null
+++ b/dev-python/argparse-manpage/argparse-manpage-1.5-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Automatically build man-pages for your Python project"
+HOMEPAGE="https://github.com/praiskup/argparse-manpage https://pypi.org/project/argparse-manpage/"
+SRC_URI="https://github.com/praiskup/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}/${P}-remove-six-dep.patch"
+)
+
+distutils_enable_tests pytest