summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-21 05:33:27 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-21 05:33:27 +0100
commit4d6125ceaa4fd04a7388aff0dbcb0a58213be7c6 (patch)
tree7769a34cfe45616a7018ca46965cf183ecdce3a7 /dev-python/aiosqlite
parentdev-python/a2wsgi: Bump to 1.10.2 (diff)
downloadgentoo-4d6125ceaa4fd04a7388aff0dbcb0a58213be7c6.tar.gz
gentoo-4d6125ceaa4fd04a7388aff0dbcb0a58213be7c6.tar.bz2
gentoo-4d6125ceaa4fd04a7388aff0dbcb0a58213be7c6.zip
dev-python/aiosqlite: Bump to 0.20.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiosqlite')
-rw-r--r--dev-python/aiosqlite/Manifest1
-rw-r--r--dev-python/aiosqlite/aiosqlite-0.20.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/aiosqlite/Manifest b/dev-python/aiosqlite/Manifest
index 831441bdeb84..cdadca4809ae 100644
--- a/dev-python/aiosqlite/Manifest
+++ b/dev-python/aiosqlite/Manifest
@@ -1 +1,2 @@
DIST aiosqlite-0.19.0.tar.gz 21832 BLAKE2B 0cd367979e84af23e7ca9965535ab6477bb78c6b2b0c6af3a8698bbde6400dee80d468b99f125ae03ab98053212170cbbaaeac5134e9f85dc66704eafa96f78f SHA512 56debffdb73b6ec98bb69ce2b711e53417cbcb06501a2dc94558157c2cd010f9f56345bcf5378a17eb064ac6bd5f3638650edffcd1f73883bdeae7476afa96e8
+DIST aiosqlite-0.20.0.tar.gz 21691 BLAKE2B 2cfa096fa10e4964eb73b0fa698bad07311a78a66258d38864d3d8957df5280fd3a4bf8cb497c9b6f3e0f3bc513a439790f3df81f7736736f73717cf60df54e4 SHA512 b0421d2b8acf90a38e33f68d8af7f0d11194c59413f074dcf7d676924adf30f0ba27dcf45e061ba1aad58c2aae49c523bfb6dc3e3fd85bf6c64052151c300be5
diff --git a/dev-python/aiosqlite/aiosqlite-0.20.0.ebuild b/dev-python/aiosqlite/aiosqlite-0.20.0.ebuild
new file mode 100644
index 000000000000..c3044dd31f49
--- /dev/null
+++ b/dev-python/aiosqlite/aiosqlite-0.20.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="asyncio bridge to the standard sqlite3 module"
+HOMEPAGE="
+ https://aiosqlite.omnilib.dev
+ https://pypi.org/project/aiosqlite/
+ https://github.com/omnilib/aiosqlite
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/typing-extensions-4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+# AttributeError: 'str' object has no attribute 'supported'
+#distutils_enable_sphinx docs dev-python/m2r