summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-08-01 11:52:34 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-08-02 01:19:38 +0200
commitc716e3b0b2dcd4c6a2c90893295165003992a794 (patch)
treeaa22be015090d5b3fc23ac0d28185bd2f4d6a400 /dev-python/PyQt5
parentdev-python/PyQtWebEngine: Drop python2_7 (diff)
downloadgentoo-c716e3b0b2dcd4c6a2c90893295165003992a794.tar.gz
gentoo-c716e3b0b2dcd4c6a2c90893295165003992a794.tar.bz2
gentoo-c716e3b0b2dcd4c6a2c90893295165003992a794.zip
dev-python/PyQt5: Drop python2_7
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-python/PyQt5')
-rw-r--r--dev-python/PyQt5/PyQt5-5.14.2-r1.ebuild (renamed from dev-python/PyQt5/PyQt5-5.14.2.ebuild)23
-rw-r--r--dev-python/PyQt5/PyQt5-5.15.0-r1.ebuild (renamed from dev-python/PyQt5/PyQt5-5.15.0.ebuild)23
2 files changed, 10 insertions, 36 deletions
diff --git a/dev-python/PyQt5/PyQt5-5.14.2.ebuild b/dev-python/PyQt5/PyQt5-5.14.2-r1.ebuild
index 04c639a05ba6..6f47872f089c 100644
--- a/dev-python/PyQt5/PyQt5-5.14.2.ebuild
+++ b/dev-python/PyQt5/PyQt5-5.14.2-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
inherit multibuild python-r1 qmake-utils
DESCRIPTION="Python bindings for the Qt framework"
@@ -54,11 +54,7 @@ REQUIRED_USE="
# Minimal supported version of Qt.
QT_PV="5.12:5"
-RDEPEND="
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-python/enum34[${PYTHON_USEDEP}]
- ' -2)
+RDEPEND="${PYTHON_DEPS}
>=dev-python/PyQt5-sip-4.19.20:=[${PYTHON_USEDEP}]
>=dev-qt/qtcore-${QT_PV}
>=dev-qt/qtxml-${QT_PV}
@@ -156,13 +152,8 @@ src_configure() {
"${myconf[@]}" || die
# Fix parallel install failure
- if python_is_python3; then
- sed -i -e '/INSTALLS += distinfo/i distinfo.depends = install_subtargets install_pep484_stubs install_qscintilla_api' \
- ${PN}.pro || die
- else
- sed -i -e '/INSTALLS += distinfo/i distinfo.depends = install_subtargets install_qscintilla_api' \
- ${PN}.pro || die
- fi
+ sed -i -e '/INSTALLS += distinfo/i distinfo.depends = install_subtargets install_pep484_stubs install_qscintilla_api' \
+ ${PN}.pro || die
# Run eqmake to respect toolchain and build flags
eqmake5 -recursive ${PN}.pro
@@ -187,11 +178,7 @@ src_install() {
done
local uic_dir=${tmp_root}$(python_get_sitedir)/${PN}/uic
- if python_is_python3; then
- rm -r "${uic_dir}"/port_v2 || die
- else
- rm -r "${uic_dir}"/port_v3 || die
- fi
+ rm -r "${uic_dir}"/port_v2 || die
multibuild_merge_root "${tmp_root}" "${D}"
python_optimize
diff --git a/dev-python/PyQt5/PyQt5-5.15.0.ebuild b/dev-python/PyQt5/PyQt5-5.15.0-r1.ebuild
index 3d51e939103e..075b00012939 100644
--- a/dev-python/PyQt5/PyQt5-5.15.0.ebuild
+++ b/dev-python/PyQt5/PyQt5-5.15.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6..9} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit multibuild python-r1 qmake-utils
DESCRIPTION="Python bindings for the Qt framework"
@@ -54,11 +54,7 @@ REQUIRED_USE="
# Minimal supported version of Qt.
QT_PV="5.12:5"
-RDEPEND="
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-python/enum34[${PYTHON_USEDEP}]
- ' -2)
+RDEPEND="${PYTHON_DEPS}
>=dev-python/PyQt5-sip-4.19.23:=[${PYTHON_USEDEP}]
>=dev-qt/qtcore-${QT_PV}
>=dev-qt/qtxml-${QT_PV}
@@ -156,13 +152,8 @@ src_configure() {
"${myconf[@]}" || die
# Fix parallel install failure
- if python_is_python3; then
- sed -i -e '/INSTALLS += distinfo/i distinfo.depends = install_subtargets install_pep484_stubs install_qscintilla_api' \
- ${PN}.pro || die
- else
- sed -i -e '/INSTALLS += distinfo/i distinfo.depends = install_subtargets install_qscintilla_api' \
- ${PN}.pro || die
- fi
+ sed -i -e '/INSTALLS += distinfo/i distinfo.depends = install_subtargets install_pep484_stubs install_qscintilla_api' \
+ ${PN}.pro || die
# Run eqmake to respect toolchain and build flags
eqmake5 -recursive ${PN}.pro
@@ -187,11 +178,7 @@ src_install() {
done
local uic_dir=${tmp_root}$(python_get_sitedir)/${PN}/uic
- if python_is_python3; then
- rm -r "${uic_dir}"/port_v2 || die
- else
- rm -r "${uic_dir}"/port_v3 || die
- fi
+ rm -r "${uic_dir}"/port_v2 || die
multibuild_merge_root "${tmp_root}" "${D}"
python_optimize