summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-08-27 14:24:13 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-08-27 15:16:03 +0200
commit15efeda80671b339913f283cec31ac93c097245d (patch)
tree1da05ad37a76590248e1f85b57c2618023fe4b9e /dev-php/theseer-tokenizer/theseer-tokenizer-1.2.1.ebuild
parentmedia-video/pipewire: bump to v0.3.34 (diff)
downloadgentoo-15efeda80671b339913f283cec31ac93c097245d.tar.gz
gentoo-15efeda80671b339913f283cec31ac93c097245d.tar.bz2
gentoo-15efeda80671b339913f283cec31ac93c097245d.zip
dev-php/theseer-tokenizer: bump to v1.2.1
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/theseer-tokenizer/theseer-tokenizer-1.2.1.ebuild')
-rw-r--r--dev-php/theseer-tokenizer/theseer-tokenizer-1.2.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-php/theseer-tokenizer/theseer-tokenizer-1.2.1.ebuild b/dev-php/theseer-tokenizer/theseer-tokenizer-1.2.1.ebuild
new file mode 100644
index 000000000000..2da5b5180736
--- /dev/null
+++ b/dev-php/theseer-tokenizer/theseer-tokenizer-1.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Convert tokenized PHP source code into XML and other formats"
+HOMEPAGE="https://github.com/theseer/tokenizer"
+SRC_URI="https://github.com/theseer/tokenizer/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+CDEPEND="dev-lang/php:*
+ dev-php/fedora-autoloader"
+
+BDEPEND="dev-php/theseer-Autoload"
+
+RDEPEND="${CDEPEND}"
+
+S="${WORKDIR}/tokenizer-${PV}"
+
+src_prepare() {
+ default
+
+ phpab \
+ --output src/autoload.php \
+ --template fedora2 \
+ --basedir src \
+ src || die
+}
+
+src_install() {
+ insinto /usr/share/php/TheSeer/Tokenizer
+ doins -r src/*
+
+ einstalldocs
+}