summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-12-20 09:16:10 -0500
committerBrian Evans <grknight@gentoo.org>2019-12-20 13:34:21 -0500
commitebaa22e55a08fa6dcaa75e5ec755f82e231c6357 (patch)
tree21f98a3b61466d031cc36475a806db4eab097639 /dev-php/sebastian-resource-operations
parentdev-php/sebastian-object-enumerator: Version bump for 3.0.3 (diff)
downloadgentoo-ebaa22e55a08fa6dcaa75e5ec755f82e231c6357.tar.gz
gentoo-ebaa22e55a08fa6dcaa75e5ec755f82e231c6357.tar.bz2
gentoo-ebaa22e55a08fa6dcaa75e5ec755f82e231c6357.zip
dev-php/sebastian-resource-operations: Version bump for 2.0.1
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php/sebastian-resource-operations')
-rw-r--r--dev-php/sebastian-resource-operations/Manifest1
-rw-r--r--dev-php/sebastian-resource-operations/sebastian-resource-operations-2.0.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-php/sebastian-resource-operations/Manifest b/dev-php/sebastian-resource-operations/Manifest
index c95957161cf4..3fedbbc8c9eb 100644
--- a/dev-php/sebastian-resource-operations/Manifest
+++ b/dev-php/sebastian-resource-operations/Manifest
@@ -1 +1,2 @@
DIST sebastian-resource-operations-1.0.0.tar.gz 6449 BLAKE2B 0f748d4792a3d4705560c79047fbdb9c6371435600dbd8373e4c60c8edc436f3487264107b7f3d76125bde3ec7b30062587c96dad7612fdc4e4132d3912813ef SHA512 d11d06c9b8b4a1507238443588f34a85836fcd65d2afdb9bcf3cecfe352cba46c9349988550e901c301db8a21f19cc960a8164653ac66e57661cebddf52ad906
+DIST sebastian-resource-operations-2.0.1.tar.gz 17772 BLAKE2B 8a98c2735973f063fefba9079bf10e1b4a1317eab2e9326bf338d50b2c278673ade93bc20fb415d4d33046575045d0e2d147b5b1ba38812c84031c7a691d1946 SHA512 991716a948f3492b2f3c886f07485fec26ad7e31f8588a2cbf6deff8ef4791e403962578590b117ed43def7753a5f44f0f8c8f92994bc58295d58db3f7d71021
diff --git a/dev-php/sebastian-resource-operations/sebastian-resource-operations-2.0.1.ebuild b/dev-php/sebastian-resource-operations/sebastian-resource-operations-2.0.1.ebuild
new file mode 100644
index 000000000000..68a1a80abaca
--- /dev/null
+++ b/dev-php/sebastian-resource-operations/sebastian-resource-operations-2.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/sebastian-//}"
+
+DESCRIPTION="Provides a list of PHP built-in functions that operate on resources"
+HOMEPAGE="http://phpunit.de"
+SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-7.1:*
+ "
+
+src_install() {
+ insinto /usr/share/php/SebastianBergmann/ResourceOperations
+ doins -r src/*
+ doins "${FILESDIR}/autoload.php"
+}