summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-06-14 20:43:57 +1200
committerKent Fredric <kentnl@gentoo.org>2017-06-14 20:43:57 +1200
commitc12611af0f7a824e7ad234e4ca3491ce74ab703d (patch)
tree387b7ddc022b27abcb6fc31a0ce92419cfc3bafb /dev-perl
parentdev-perl/Array-Window: Fix for '.' in @INC re bug #614652 (diff)
downloadgentoo-c12611af0f7a824e7ad234e4ca3491ce74ab703d.tar.gz
gentoo-c12611af0f7a824e7ad234e4ca3491ce74ab703d.tar.bz2
gentoo-c12611af0f7a824e7ad234e4ca3491ce74ab703d.zip
dev-perl/Authen-PAM: Fix for '.' in @INC re bug #614660
require "foo.cfg" Relied on '.' being in @INC to work, and can be worked around by using explict require "./foo.cfg" Bug: https://bugs.gentoo.org/614660 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Authen-PAM/Authen-PAM-0.160.0-r1.ebuild4
-rw-r--r--dev-perl/Authen-PAM/files/no-dot-inc.patch32
2 files changed, 34 insertions, 2 deletions
diff --git a/dev-perl/Authen-PAM/Authen-PAM-0.160.0-r1.ebuild b/dev-perl/Authen-PAM/Authen-PAM-0.160.0-r1.ebuild
index b38fdd7ce2d0..910cb91d7991 100644
--- a/dev-perl/Authen-PAM/Authen-PAM-0.160.0-r1.ebuild
+++ b/dev-perl/Authen-PAM/Authen-PAM-0.160.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -15,5 +15,5 @@ IUSE=""
RDEPEND="virtual/pam"
DEPEND="${RDEPEND}"
-
+PATCHES=("${FILESDIR}/no-dot-inc.patch")
export OPTIMIZE="$CFLAGS"
diff --git a/dev-perl/Authen-PAM/files/no-dot-inc.patch b/dev-perl/Authen-PAM/files/no-dot-inc.patch
new file mode 100644
index 000000000000..fa1d5492da98
--- /dev/null
+++ b/dev-perl/Authen-PAM/files/no-dot-inc.patch
@@ -0,0 +1,32 @@
+From cad0178cc0bdacd33f7faf2f86afa6d2a118f730 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Wed, 14 Jun 2017 20:39:17 +1200
+Subject: [PATCH] Fix for '.' removal from @INC in Perl 5.26
+
+ require "foo.ext"
+
+Never really implied it would load files from ./ , it only did so
+as a side effect of '.' being in @INC.
+
+The only way which works after 5.26 is to use an explicit ./ prefix,
+which is special-cased for this purpose.
+---
+ Makefile.PL | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index f6e2d49..c7ffd45 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -10,7 +10,7 @@ sub configure {
+
+ # returns a reference to anonymous hash which is then interpreted as
+ # additional options to the WriteMakeFile
+- $options = require "pam.cfg";
++ $options = require "./pam.cfg";
+
+ if ( $Config{'osname'} eq 'solaris' && $Config{'osvers'} eq '2.6') {
+ print "Adding a workaround for a bug in the Solaris 2.6 pam library\n";
+--
+2.13.1
+