summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-11-13 04:28:55 +0000
committerSam James <sam@gentoo.org>2023-11-13 04:34:40 +0000
commit17d5218d5ae863e8416235cd3c587631e18f09ca (patch)
tree60b9d06d82817b87bcbc64574005b01067ed6695 /dev-perl/Time-Out/Time-Out-0.220.0.ebuild
parentdev-perl/PAR: add 1.19.0 (diff)
downloadgentoo-17d5218d5ae863e8416235cd3c587631e18f09ca.tar.gz
gentoo-17d5218d5ae863e8416235cd3c587631e18f09ca.tar.bz2
gentoo-17d5218d5ae863e8416235cd3c587631e18f09ca.zip
dev-perl/Time-Out: add 0.220.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/Time-Out/Time-Out-0.220.0.ebuild')
-rw-r--r--dev-perl/Time-Out/Time-Out-0.220.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/Time-Out/Time-Out-0.220.0.ebuild b/dev-perl/Time-Out/Time-Out-0.220.0.ebuild
new file mode 100644
index 000000000000..9db765563541
--- /dev/null
+++ b/dev-perl/Time-Out/Time-Out-0.220.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=SVW
+DIST_VERSION=0.22
+inherit perl-module
+
+DESCRIPTION="Easily timeout long running operations"
+
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-perl/Try-Tiny
+"
+BDEPEND="
+ ${RDEPEND}
+ >=dev-perl/ExtUtils-MakeMaker-CPANfile-0.90.0
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Test-Fatal
+ dev-perl/Test-Needs
+ )
+"
+
+PERL_RM_FILES=( "t/pod.t" )