summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/MooseX-ClassAttribute
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/MooseX-ClassAttribute')
-rw-r--r--dev-perl/MooseX-ClassAttribute/Manifest2
-rw-r--r--dev-perl/MooseX-ClassAttribute/MooseX-ClassAttribute-0.260.0.ebuild27
-rw-r--r--dev-perl/MooseX-ClassAttribute/MooseX-ClassAttribute-0.270.0.ebuild27
-rw-r--r--dev-perl/MooseX-ClassAttribute/metadata.xml18
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-perl/MooseX-ClassAttribute/Manifest b/dev-perl/MooseX-ClassAttribute/Manifest
new file mode 100644
index 000000000000..50fb58c986a5
--- /dev/null
+++ b/dev-perl/MooseX-ClassAttribute/Manifest
@@ -0,0 +1,2 @@
+DIST MooseX-ClassAttribute-0.26.tar.gz 19050 SHA256 6aa89dd7bf3135ff06bd990e6b77a74a911cd0b68674dced170a2e0f4f88b2e8 SHA512 17a54453f25614d9283a276f28ee93d37ed694c69eaf8398886dbfec15d498904d9147aff41c626d6076004e552d8bb6797e465d873d9fbb966ee03fc3b3803f WHIRLPOOL d0965caa2f6ee10bc30d350d7d41ee578174a65b491f8e633a15f58edd4da4f05a014ef2342c0588e73f09ca8a57c09d261e8461f989a48faff6867b20ff2bc5
+DIST MooseX-ClassAttribute-0.27.tar.gz 20132 SHA256 77d97b2c642f96073df5d778a1487ec9483cd0d0661ab50856931af13aa8bf93 SHA512 0734fc114f717aca8ea9860c978d8898b2db69bda8d4b2ac7f9d269c38154fb800a0eb07318e02ec0be9bb38df91f8909aa34181f7bb5b55572051195d8da256 WHIRLPOOL 74c33abcafeb52dfc3f0019c69eed7bb3164861d9d27bb2728e5441e3acc1fa4c249085b01da3565fa51854ee9eda666a37dd7cd1a0f39c314e201f2533984ec
diff --git a/dev-perl/MooseX-ClassAttribute/MooseX-ClassAttribute-0.260.0.ebuild b/dev-perl/MooseX-ClassAttribute/MooseX-ClassAttribute-0.260.0.ebuild
new file mode 100644
index 000000000000..30a0d98254b0
--- /dev/null
+++ b/dev-perl/MooseX-ClassAttribute/MooseX-ClassAttribute-0.260.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DROLSKY
+MODULE_VERSION=0.26
+inherit perl-module
+
+DESCRIPTION="Declare class attributes Moose-style"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-perl/Moose-1.230
+ >=dev-perl/namespace-autoclean-0.11
+ >=dev-perl/namespace-clean-0.200"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.31
+ test? ( >=virtual/perl-Test-Simple-0.88
+ dev-perl/Test-Fatal
+ >=dev-perl/Test-Requires-0.05 )"
+
+SRC_TEST=do
diff --git a/dev-perl/MooseX-ClassAttribute/MooseX-ClassAttribute-0.270.0.ebuild b/dev-perl/MooseX-ClassAttribute/MooseX-ClassAttribute-0.270.0.ebuild
new file mode 100644
index 000000000000..988f93214ce7
--- /dev/null
+++ b/dev-perl/MooseX-ClassAttribute/MooseX-ClassAttribute-0.270.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DROLSKY
+MODULE_VERSION=0.27
+inherit perl-module
+
+DESCRIPTION="Declare class attributes Moose-style"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-perl/Moose-1.230
+ >=dev-perl/namespace-autoclean-0.11
+ >=dev-perl/namespace-clean-0.200"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.31
+ test? ( >=virtual/perl-Test-Simple-0.88
+ dev-perl/Test-Fatal
+ >=dev-perl/Test-Requires-0.05 )"
+
+SRC_TEST=do
diff --git a/dev-perl/MooseX-ClassAttribute/metadata.xml b/dev-perl/MooseX-ClassAttribute/metadata.xml
new file mode 100644
index 000000000000..1c030ed33d18
--- /dev/null
+++ b/dev-perl/MooseX-ClassAttribute/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">MooseX-ClassAttribute</remote-id>
+ <remote-id type="cpan-module">MooseX::ClassAttribute</remote-id>
+ <remote-id type="cpan-module">MooseX::ClassAttribute::Meta::Role::Attribute</remote-id>
+ <remote-id type="cpan-module">MooseX::ClassAttribute::Trait::Application</remote-id>
+ <remote-id type="cpan-module">MooseX::ClassAttribute::Trait::Application::ToClass</remote-id>
+ <remote-id type="cpan-module">MooseX::ClassAttribute::Trait::Application::ToRole</remote-id>
+ <remote-id type="cpan-module">MooseX::ClassAttribute::Trait::Attribute</remote-id>
+ <remote-id type="cpan-module">MooseX::ClassAttribute::Trait::Class</remote-id>
+ <remote-id type="cpan-module">MooseX::ClassAttribute::Trait::Mixin::HasClassAttributes</remote-id>
+ <remote-id type="cpan-module">MooseX::ClassAttribute::Trait::Role</remote-id>
+ <remote-id type="cpan-module">MooseX::ClassAttribute::Trait::Role::Composite</remote-id>
+ </upstream>
+</pkgmetadata>