summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-07-19 13:02:52 +1200
committerKent Fredric <kentnl@gentoo.org>2016-07-19 13:02:52 +1200
commit52c8a653054bd44faa4100ecbe0f6f7cc4436946 (patch)
treeebc5248fd72e1ea8285eb8ffd3caeb985df02c39 /dev-perl/Carp-Clan/Carp-Clan-6.60.0.ebuild
parentdev-perl/Capture-Tiny: Bump to version 0.420.0 (diff)
downloadgentoo-52c8a653054bd44faa4100ecbe0f6f7cc4436946.tar.gz
gentoo-52c8a653054bd44faa4100ecbe0f6f7cc4436946.tar.bz2
gentoo-52c8a653054bd44faa4100ecbe0f6f7cc4436946.zip
dev-perl/Carp-Clan: Bump to version 6.60.0
- EAPI6 - Removed author tests - Update metadata.xml Upstream: - Tests fixed for perl 5.25+ Keywords: - m68k dropped due to unsatisfied by dev-perl/Test-Exception Package-Manager: portage-2.3.0 RepoMan-Options: --ignore-arches --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
Diffstat (limited to 'dev-perl/Carp-Clan/Carp-Clan-6.60.0.ebuild')
-rw-r--r--dev-perl/Carp-Clan/Carp-Clan-6.60.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-perl/Carp-Clan/Carp-Clan-6.60.0.ebuild b/dev-perl/Carp-Clan/Carp-Clan-6.60.0.ebuild
new file mode 100644
index 000000000000..703afafff0ea
--- /dev/null
+++ b/dev-perl/Carp-Clan/Carp-Clan-6.60.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=KENTNL
+DIST_VERSION=6.06
+inherit perl-module
+
+DESCRIPTION="Report errors from perspective of caller of a clan of modules"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? ( dev-perl/Test-Exception )"
+
+src_test() {
+ perl_rm_files t/01pod.t t/03yaml.t
+ perl-module_src_test
+}