summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-06-30 21:58:41 +0200
committerAlfredo Tupone <tupone@gentoo.org>2023-06-30 22:05:38 +0200
commit9de4bf79591fb17f6c098b6fa4d7fb3c2f890270 (patch)
treea978791e39085bcc941d52b242d8c1b7fc174a65 /dev-ml/ppx_optional/ppx_optional-0.16.0.ebuild
parentdev-ml/ppx_pipebang: add 0.16.0 (diff)
downloadgentoo-9de4bf79591fb17f6c098b6fa4d7fb3c2f890270.tar.gz
gentoo-9de4bf79591fb17f6c098b6fa4d7fb3c2f890270.tar.bz2
gentoo-9de4bf79591fb17f6c098b6fa4d7fb3c2f890270.zip
dev-ml/ppx_optional: add 0.16.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_optional/ppx_optional-0.16.0.ebuild')
-rw-r--r--dev-ml/ppx_optional/ppx_optional-0.16.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ml/ppx_optional/ppx_optional-0.16.0.ebuild b/dev-ml/ppx_optional/ppx_optional-0.16.0.ebuild
new file mode 100644
index 000000000000..6ee953269bce
--- /dev/null
+++ b/dev-ml/ppx_optional/ppx_optional-0.16.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Pattern matching on flat options"
+HOMEPAGE="https://github.com/janestreet/ppx_optional"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-lang/ocaml-4.14
+ dev-ml/base:${SLOT}
+ >=dev-ml/ppxlib-0.28.0:=
+ dev-ml/result:=
+"
+RDEPEND="${DEPEND}"