summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-05 18:00:49 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-05 21:59:02 +0100
commitc7503baa9ca4d7b62d82202b7db834d41ffb9a1c (patch)
tree4c15926577f28c082287b075ff7644846d02f708 /dev-ml/ppx_here
parentdev-ml/ppx_inline_test: Use proper install method. (diff)
downloadgentoo-c7503baa9ca4d7b62d82202b7db834d41ffb9a1c.tar.gz
gentoo-c7503baa9ca4d7b62d82202b7db834d41ffb9a1c.tar.bz2
gentoo-c7503baa9ca4d7b62d82202b7db834d41ffb9a1c.zip
dev-ml/ppx_here: use proper install method
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_here')
-rw-r--r--dev-ml/ppx_here/ppx_here-113.24.00.ebuild24
1 files changed, 16 insertions, 8 deletions
diff --git a/dev-ml/ppx_here/ppx_here-113.24.00.ebuild b/dev-ml/ppx_here/ppx_here-113.24.00.ebuild
index 74f426c21d29..3b4dbe019540 100644
--- a/dev-ml/ppx_here/ppx_here-113.24.00.ebuild
+++ b/dev-ml/ppx_here/ppx_here-113.24.00.ebuild
@@ -6,10 +6,9 @@ EAPI="5"
inherit oasis
-MY_P=${PN/-/_}-${PV}
DESCRIPTION="Expands [%here] into its location"
HOMEPAGE="http://www.janestreet.com/ocaml"
-SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0/${PV}"
@@ -21,13 +20,22 @@ DEPEND="dev-ml/ppx_tools:=
dev-ml/ppx_core:="
RDEPEND="${DEPEND}"
-DEPEND="${RDEPEND} dev-ml/oasis"
+DEPEND="${RDEPEND} dev-ml/opam"
-S="${WORKDIR}/${MY_P}"
+src_configure() {
+ emake setup.exe
+ OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
-DOCS=( CHANGES.md )
+src_compile() {
+ emake
+}
-src_prepare() {
- sed -i -e "s/Executable ppx/Executable ${PN}/" _oasis || die
- oasis setup || die
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc CHANGES.md
}