summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-04-30 18:02:11 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-04-30 18:02:11 +0200
commit9ea57f3f0febdefdbe0ae810169ed485b165808b (patch)
treef981076d0332d00ea41e4da1aa4bbbff4b55f815 /dev-ml/opam/opam-1.2.2-r1.ebuild
parentdev-ml/cudf: add := dep on cppo. (diff)
downloadgentoo-9ea57f3f0febdefdbe0ae810169ed485b165808b.tar.gz
gentoo-9ea57f3f0febdefdbe0ae810169ed485b165808b.tar.bz2
gentoo-9ea57f3f0febdefdbe0ae810169ed485b165808b.zip
dev-ml/opam: apply debian patch, backported from upstream, to check certicates when downloading. Bug #580586
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/opam/opam-1.2.2-r1.ebuild')
-rw-r--r--dev-ml/opam/opam-1.2.2-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-ml/opam/opam-1.2.2-r1.ebuild b/dev-ml/opam/opam-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..2b94b7e93d95
--- /dev/null
+++ b/dev-ml/opam/opam-1.2.2-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A source-based package manager for OCaml"
+HOMEPAGE="http://opam.ocaml.org/"
+LICENSE="LGPL-3-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+if [[ ${PV} != 9999 ]]; then
+ SRC_URI="https://github.com/ocaml/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ocaml/opam.git"
+fi
+
+DEPEND="dev-lang/ocaml:=
+ || ( net-misc/wget net-misc/curl )
+ dev-ml/extlib:=
+ dev-ml/ocaml-re:=
+ dev-ml/ocamlgraph:=
+ dev-ml/cmdliner:=
+ dev-ml/cudf:=
+ >=dev-ml/dose3-4:=
+ dev-ml/uutf:=
+ dev-ml/jsonm:=
+"
+RDEPEND="${DEPEND}
+ dev-ml/findlib
+"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/0001-Port-to-Dose3-4.0.1.patch" \
+ "${FILESDIR}/no-insecure.patch"
+}
+
+src_compile() {
+ emake -j1
+ cd doc
+ emake man
+}
+
+src_test() {
+ EMAIL=foo@bar.com emake -j1 tests
+}
+
+src_install() {
+ default
+ emake DESTDIR="${D}" OPAMINSTALLER_FLAGS="--prefix=\"${ED}/usr\" --libdir=\"${D}/$(ocamlc -where)\"" libinstall
+}