summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-03-01 19:21:06 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-03-01 19:21:06 +0100
commitc90142b9b7f5349a54bc57828af461affcd8c36c (patch)
treedd35fe4c368a8b01d0a704501b58c7da4bec79bf /dev-ml/dyn/dyn-3.7.0.ebuild
parentdev-ml/ordering: add 3.7.0 (diff)
downloadgentoo-c90142b9b7f5349a54bc57828af461affcd8c36c.tar.gz
gentoo-c90142b9b7f5349a54bc57828af461affcd8c36c.tar.bz2
gentoo-c90142b9b7f5349a54bc57828af461affcd8c36c.zip
dev-ml/dyn: add 3.7.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/dyn/dyn-3.7.0.ebuild')
-rw-r--r--dev-ml/dyn/dyn-3.7.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/dyn/dyn-3.7.0.ebuild b/dev-ml/dyn/dyn-3.7.0.ebuild
new file mode 100644
index 000000000000..a3d55d2d7132
--- /dev/null
+++ b/dev-ml/dyn/dyn-3.7.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune multiprocessing
+
+DESCRIPTION="Dynamic type"
+HOMEPAGE="https://github.com/ocaml/dune"
+SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz
+ -> dune-${PV}.tar.gz"
+S="${WORKDIR}/dune-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+BDEPEND=">=dev-ml/dune-3.5"
+DEPEND="~dev-ml/ordering-${PV}:=
+ dev-ml/pp:="
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ dune build -p "${PN}" @install -j $(makeopts_jobs) --profile release || die
+}