summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilfried Holzke <gentoo@holzke.net>2020-08-23 11:09:09 +0200
committerCraig Andrews <candrews@gentoo.org>2020-08-23 10:47:38 -0400
commitf3be5edbe2675ee61c00cb1c11113c9afe145ae0 (patch)
tree3085f6b4779eeb5b192503c73b443ab86d448940 /dev-libs/rocclr
parentmedia-libs/codec2: update to 0.9.2 (diff)
downloadgentoo-f3be5edbe2675ee61c00cb1c11113c9afe145ae0.tar.gz
gentoo-f3be5edbe2675ee61c00cb1c11113c9afe145ae0.tar.bz2
gentoo-f3be5edbe2675ee61c00cb1c11113c9afe145ae0.zip
dev-libs/rocclr: Correction of a path in a cmake file
Signed-off-by: Wilfried Holzke <gentoo@holzke.net> Package-Manager: Portage-2.3.103, Repoman-2.3.23 Closes: https://github.com/gentoo/gentoo/pull/17231 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/rocclr')
-rw-r--r--dev-libs/rocclr/rocclr-3.7.0-r1.ebuild (renamed from dev-libs/rocclr/rocclr-3.7.0.ebuild)7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-libs/rocclr/rocclr-3.7.0.ebuild b/dev-libs/rocclr/rocclr-3.7.0-r1.ebuild
index 13316648b27a..04b209388e32 100644
--- a/dev-libs/rocclr/rocclr-3.7.0.ebuild
+++ b/dev-libs/rocclr/rocclr-3.7.0-r1.ebuild
@@ -34,3 +34,10 @@ src_configure() {
)
cmake_src_configure
}
+
+src_install() {
+ cmake_src_install
+
+ # This should be fixed in the CMakeLists.txt
+ sed -e "s:${BUILD_DIR}:${EPREFIX}/usr:" -i "${D}/usr/lib/cmake/rocclr/ROCclrConfig.cmake" || die
+}