summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-04-22 18:29:22 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-04-29 17:08:42 +0200
commit2c4632e77aeb56fc741f01622ec44cfec694e3d3 (patch)
tree26eed6731a40e053b096fbd30c65606a520efcdc /dev-libs/msgpack
parentsys-power/power-profiles-daemon: Version bump to 0.13 (diff)
downloadgentoo-2c4632e77aeb56fc741f01622ec44cfec694e3d3.tar.gz
gentoo-2c4632e77aeb56fc741f01622ec44cfec694e3d3.tar.bz2
gentoo-2c4632e77aeb56fc741f01622ec44cfec694e3d3.zip
dev-libs/msgpack: drop 3.3.0-r1
Bug: https://bugs.gentoo.org/901327 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/msgpack')
-rw-r--r--dev-libs/msgpack/Manifest1
-rw-r--r--dev-libs/msgpack/metadata.xml3
-rw-r--r--dev-libs/msgpack/msgpack-3.3.0-r1.ebuild77
3 files changed, 0 insertions, 81 deletions
diff --git a/dev-libs/msgpack/Manifest b/dev-libs/msgpack/Manifest
index 1fded80f469a..7d06ba598e97 100644
--- a/dev-libs/msgpack/Manifest
+++ b/dev-libs/msgpack/Manifest
@@ -1,3 +1,2 @@
-DIST msgpack-3.3.0.tar.gz 508001 BLAKE2B 3017c44689f8afbf078b9c498449e21b4e3b87591c50a37bf9ae73869dab550819f24d6e5179a3600df297aa2c024e5a7fe1defcbab7c0f1aff826870de2ab32 SHA512 ad3e32edc8c6afd70282b3d4b493c2ffe74a697c41bd1f39030c5b4752cccefaa965bc049d4c2e63103a210bf714dc3bddd474691bc067d1475ae017593f55e6
DIST msgpack-c-5.0.0.tar.gz 69275 BLAKE2B 9c4ebc60387028cba04d5a8f4d97ca3cf6caa3db93fa7da1a90089d63cd58b36a7fb387b4fd5410d0c422719c1aed6d479418d3cbc011b609afb49cf89c4d0e3 SHA512 f61f19c7dcb5ef2a94cd3fb84e9b090e236caa922f590496e6455bd49a3d001021b55d0f28cea3ce3c35558bedb64f2f932c0e107fb15e6efc6855b99cbe4de6
DIST msgpack-c-6.0.0.tar.gz 69341 BLAKE2B e5f4f99266e568e7df46064803f869874559b766d32a3eb61f722b610753dd20eb755657eab305079ce0c3c6798848d6511b56d9e60cfedab6fa809cb2f1cb2f SHA512 77a2a3c984e04fcda298ae34571b6826f1d4f6e53b5f7166992269421ae3153b986ed69ba0360347920047e38f6941680bc9e38563ec79f15591bf8d66cd7978
diff --git a/dev-libs/msgpack/metadata.xml b/dev-libs/msgpack/metadata.xml
index 7d2a4745c20f..738a3c879cff 100644
--- a/dev-libs/msgpack/metadata.xml
+++ b/dev-libs/msgpack/metadata.xml
@@ -5,9 +5,6 @@
<email>vim@gentoo.org</email>
<name>Gentoo Vim Project</name>
</maintainer>
- <use>
- <flag name="boost">Enable boost support</flag>
- </use>
<upstream>
<remote-id type="github">msgpack/msgpack-c</remote-id>
</upstream>
diff --git a/dev-libs/msgpack/msgpack-3.3.0-r1.ebuild b/dev-libs/msgpack/msgpack-3.3.0-r1.ebuild
deleted file mode 100644
index 4c9eb713672c..000000000000
--- a/dev-libs/msgpack/msgpack-3.3.0-r1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake-multilib
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/${PN}/${PN}-c.git"
-else
- SRC_URI="https://github.com/${PN}/${PN}-c/releases/download/cpp-${PV}/${P}.tar.gz"
- KEYWORDS="amd64 ~arm arm64 ~riscv x86 ~amd64-linux ~x86-linux ~x64-macos"
-fi
-
-DESCRIPTION="MessagePack is a binary-based efficient data interchange format"
-HOMEPAGE="https://msgpack.org/ https://github.com/msgpack/msgpack-c/"
-
-LICENSE="Boost-1.0"
-SLOT="0/2"
-IUSE="boost +cxx doc examples test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="doc? ( app-doc/doxygen[dot] )"
-RDEPEND="boost? ( dev-libs/boost[context,${MULTILIB_USEDEP}] )
- !dev-cpp/msgpack-cxx"
-DEPEND="${RDEPEND}
- test? (
- >=dev-cpp/gtest-1.6.0-r2[${MULTILIB_USEDEP}]
- sys-libs/zlib[${MULTILIB_USEDEP}]
- )
-"
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DMSGPACK_BOOST="$(usex boost)"
- -DMSGPACK_ENABLE_CXX="$(usex cxx)"
- -DMSGPACK_BUILD_TESTS="$(usex test)"
- # don't build the examples
- -DMSGPACK_BUILD_EXAMPLES=OFF
- # enable C++11 by default
- -DMSGPACK_CXX11=ON
- )
-
- cmake_src_configure
-}
-
-multilib_src_compile() {
- cmake_src_compile
-
- if multilib_is_native_abi && use doc; then
- cmake_build doxygen
- fi
-}
-
-multilib_src_install() {
- if multilib_is_native_abi; then
- if use doc; then
- local HTML_DOCS=( "${BUILD_DIR}"/docs/. )
-
- mkdir docs || die
- mv doc_c/html docs/c || die
-
- if use cxx; then
- mv doc_cpp/html docs/cpp || die
- fi
- fi
-
- if use examples; then
- docinto examples
- dodoc -r "${WORKDIR}/${P}/example/."
- docompress -x /usr/share/doc/${PF}/examples
- fi
- fi
-
- cmake_src_install
-}