summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/log4sh
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/log4sh')
-rw-r--r--dev-libs/log4sh/Manifest2
-rw-r--r--dev-libs/log4sh/files/log4sh-1.2.5-fix-insecure-tmp-creation.diff11
-rw-r--r--dev-libs/log4sh/log4sh-1.2.5-r1.ebuild42
-rw-r--r--dev-libs/log4sh/log4sh-1.4.2.ebuild48
-rw-r--r--dev-libs/log4sh/metadata.xml11
5 files changed, 114 insertions, 0 deletions
diff --git a/dev-libs/log4sh/Manifest b/dev-libs/log4sh/Manifest
new file mode 100644
index 000000000000..e3d6a1fb0f21
--- /dev/null
+++ b/dev-libs/log4sh/Manifest
@@ -0,0 +1,2 @@
+DIST log4sh-1.2.5.tgz 33746 SHA256 d907e8a4d4ec4749eb603d673752213a80fec7c3778b4b43155059f29e59fb3f SHA512 5890be36bb8d1bc9e789f1b180c2dde7071683091b7013f91cdfd92b401747abe4969d66984e3a763f1d74e49a6cca86e82e52c30725c70acd5ee9efe20c733c WHIRLPOOL 2f1bbf4ecf236b67bcdd0db820c9cdd10125ef916ae5912d4bb961eb970c31a6869c7f0f8f09ec7a64d7567acf621b996077269e20ac1c48db2fb033871b52ab
+DIST log4sh-1.4.2.tgz 91994 SHA256 bb5b556fa6069956128144ed22914f5b4be24147cbe2c7efd474f274c2e28f33 SHA512 f4b983e352c94b33b355a2e743e8431cff4bf6c24b4db18087556d5a8d10ee458c2216f7b9175519e3904051e34f61b2add8faacac0b125c61cde2d76538b290 WHIRLPOOL d288501993d72061654ccff999d08877ad696f168aa7932ceff12b1c046691eb778a3943b44a980d94b7ec0dd408e0d5e879da450c0288f7122af9123cd520ca
diff --git a/dev-libs/log4sh/files/log4sh-1.2.5-fix-insecure-tmp-creation.diff b/dev-libs/log4sh/files/log4sh-1.2.5-fix-insecure-tmp-creation.diff
new file mode 100644
index 000000000000..533b3615b21a
--- /dev/null
+++ b/dev-libs/log4sh/files/log4sh-1.2.5-fix-insecure-tmp-creation.diff
@@ -0,0 +1,11 @@
+--- src/shell/log4sh.orig 2005-06-20 13:35:51.583341280 +0100
++++ src/shell/log4sh 2005-06-20 13:37:45.120081072 +0100
+@@ -357,7 +357,7 @@
+ {
+ _file=$1
+
+- _tmpFile="/tmp/log4sh.$$"
++ _tmpFile=`mktemp /tmp/log4sh.XXXXXX`
+ grep "^log4sh\." $_file >$_tmpFile
+ _rp_count=`wc -l $_tmpFile |awk '{print $1}'`
+ _rp_i=1
diff --git a/dev-libs/log4sh/log4sh-1.2.5-r1.ebuild b/dev-libs/log4sh/log4sh-1.2.5-r1.ebuild
new file mode 100644
index 000000000000..599ee52a5910
--- /dev/null
+++ b/dev-libs/log4sh/log4sh-1.2.5-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="A flexible logging framework for shell scripts"
+HOMEPAGE="http://forestent.com/products/log4sh/"
+SRC_URI="http://forestent.com/dist/${PN}/${P}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~ppc x86"
+IUSE=""
+
+RDEPEND="app-shells/bash"
+
+src_unpack() {
+ unpack ${A} && cd ${S}
+ # bug 94069
+ epatch ${FILESDIR}/${P}-fix-insecure-tmp-creation.diff
+}
+
+src_test() {
+ make test || die "make test failed"
+}
+
+src_install() {
+ insinto /usr/lib/log4sh
+ doins build/log4sh || die "Failed to install log4sh"
+
+ dodoc doc/CHANGES doc/TODO
+ dohtml doc/*.{html,css}
+ docinto examples
+ dodoc src/examples/*
+}
+
+pkg_postinst() {
+ echo
+ elog "To use log4sh, have your script source /usr/lib/log4sh/log4sh."
+ echo
+}
diff --git a/dev-libs/log4sh/log4sh-1.4.2.ebuild b/dev-libs/log4sh/log4sh-1.4.2.ebuild
new file mode 100644
index 000000000000..ba5dd293f3f3
--- /dev/null
+++ b/dev-libs/log4sh/log4sh-1.4.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A flexible logging framework for shell scripts"
+HOMEPAGE="http://sourceforge.net/projects/log4sh"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc x86"
+IUSE="examples"
+
+RDEPEND="app-shells/bash"
+
+src_compile() {
+ emake build
+}
+
+src_test() {
+ # testsuite needs USER variable
+ export USER="$(whoami)"
+ make test || die "make test failed"
+}
+
+src_install() {
+ insinto /usr/lib/log4sh
+ doins build/log4sh
+
+ dodoc doc/*.txt
+ dohtml doc/*.{html,css}
+
+ if use examples; then
+ docinto examples
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc src/examples/*
+ fi
+}
+
+pkg_postinst() {
+ elog "To use log4sh, have your script source /usr/lib/log4sh/log4sh"
+ elog "If you want to use remote logging, you should install package,"
+ elog "that provides netcat binary (for example - net-analyzer/netcat)"
+}
diff --git a/dev-libs/log4sh/metadata.xml b/dev-libs/log4sh/metadata.xml
new file mode 100644
index 000000000000..7fde4085681b
--- /dev/null
+++ b/dev-libs/log4sh/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">log4sh</remote-id>
+ </upstream>
+</pkgmetadata>