summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-06-17 23:41:45 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-06-18 00:18:00 +0200
commit370734c8591ca149bf2b5a62c9244cbad221da9c (patch)
treea4dd2e84e9171f6cfb5e7c962a1e69a2dc4a479d /dev-libs/libp11/libp11-0.4.11-r1.ebuild
parentdev-libs/botan: rev bump for commit eb9a82cd4 (diff)
downloadgentoo-370734c8591ca149bf2b5a62c9244cbad221da9c.tar.gz
gentoo-370734c8591ca149bf2b5a62c9244cbad221da9c.tar.bz2
gentoo-370734c8591ca149bf2b5a62c9244cbad221da9c.zip
dev-libs/libp11: rev bump for commit 548461af2
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-libs/libp11/libp11-0.4.11-r1.ebuild')
-rw-r--r--dev-libs/libp11/libp11-0.4.11-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/libp11/libp11-0.4.11-r1.ebuild b/dev-libs/libp11/libp11-0.4.11-r1.ebuild
new file mode 100644
index 000000000000..17e3b7767447
--- /dev/null
+++ b/dev-libs/libp11/libp11-0.4.11-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Abstraction layer to simplify PKCS#11 API"
+HOMEPAGE="https://github.com/opensc/libp11/wiki"
+SRC_URI="https://github.com/OpenSC/${PN}/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="bindist doc static-libs"
+
+RDEPEND="
+ dev-libs/openssl:0=[bindist(-)=]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_enable doc api-doc)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}