summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2017-12-21 16:03:03 -0500
committerCraig Andrews <candrews@gentoo.org>2017-12-21 16:03:18 -0500
commit0fa29e83d83d8b7762448b5bf7d012e4cb8e55bd (patch)
tree92a61716f0699182eef7de054743c263312bfab0 /dev-libs/libfmt/libfmt-4.1.0.ebuild
parentsys-libs/glibc: Unkeyworded, untested patchset/revision bumps (diff)
downloadgentoo-0fa29e83d83d8b7762448b5bf7d012e4cb8e55bd.tar.gz
gentoo-0fa29e83d83d8b7762448b5bf7d012e4cb8e55bd.tar.bz2
gentoo-0fa29e83d83d8b7762448b5bf7d012e4cb8e55bd.zip
dev-libs/libfmt: 4.1.0 version bump
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-libs/libfmt/libfmt-4.1.0.ebuild')
-rw-r--r--dev-libs/libfmt/libfmt-4.1.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/libfmt/libfmt-4.1.0.ebuild b/dev-libs/libfmt/libfmt-4.1.0.ebuild
new file mode 100644
index 000000000000..51fea82ad48f
--- /dev/null
+++ b/dev-libs/libfmt/libfmt-4.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib versionator
+
+DESCRIPTION="Small, safe and fast formatting library"
+HOMEPAGE="https://github.com/fmtlib/fmt"
+
+LICENSE="BSD-2"
+IUSE="test"
+SLOT="0/$(get_major_version)"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/fmtlib/fmt.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/fmtlib/fmt/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/fmt-${PV}"
+fi
+
+DEPEND=""
+RDEPEND=""
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DFMT_CMAKE_DIR="$(get_libdir)/cmake/fmt"
+ -DFMT_LIB_DIR="$(get_libdir)"
+ -DFMT_TEST=$(usex test)
+ -DBUILD_SHARED_LIBS=ON
+ )
+ cmake-utils_src_configure
+}