summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-02-04 12:01:14 +0100
committerJeroen Roovers <jer@gentoo.org>2017-02-04 12:01:14 +0100
commit2162b47eb7f8637a486cae3ebb99bbd6cdc60882 (patch)
tree1047429527e2de863b4044d13472750ba716ee26 /dev-libs/libevent
parentnet-analyzer/nagios-check_rbl: Stable for HPPA (bug #578646). (diff)
downloadgentoo-2162b47eb7f8637a486cae3ebb99bbd6cdc60882.tar.gz
gentoo-2162b47eb7f8637a486cae3ebb99bbd6cdc60882.tar.bz2
gentoo-2162b47eb7f8637a486cae3ebb99bbd6cdc60882.zip
dev-libs/libevent: Reinstate 2.0.22-r2 (bug #608180).
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-libs/libevent')
-rw-r--r--dev-libs/libevent/libevent-2.0.22-r2.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/dev-libs/libevent/libevent-2.0.22-r2.ebuild b/dev-libs/libevent/libevent-2.0.22-r2.ebuild
new file mode 100644
index 000000000000..1192bd9e6cf3
--- /dev/null
+++ b/dev-libs/libevent/libevent-2.0.22-r2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils libtool multilib-minimal
+
+MY_P="${P}-stable"
+
+DESCRIPTION="A library to execute a function when a specific event occurs on a file descriptor"
+HOMEPAGE="http://libevent.org/"
+SRC_URI="mirror://sourceforge/levent/files/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+# libevent-2.0.so.5
+SLOT="0/2.0-5"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug libressl +ssl static-libs test +threads"
+
+DEPEND="
+ ssl? (
+ !libressl? ( >=dev-libs/openssl-1.0.1h-r2[${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
+ )
+"
+RDEPEND="
+ ${DEPEND}
+ !<=dev-libs/9libs-1.0
+"
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/event2/event-config.h
+)
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( README ChangeLog )
+
+src_prepare() {
+ elibtoolize
+
+ # don't waste time building tests/samples
+ # https://github.com/libevent/libevent/pull/143
+ # https://github.com/libevent/libevent/pull/144
+ sed -i \
+ -e 's|^\(SUBDIRS =.*\)sample test\(.*\)$|\1\2|' \
+ Makefile.in || die "sed Makefile.in failed"
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ $(use_enable debug debug-mode) \
+ $(use_enable debug malloc-replacement) \
+ $(use_enable ssl openssl) \
+ $(use_enable static-libs static) \
+ $(use_enable threads thread-support)
+}
+
+src_test() {
+ # The test suite doesn't quite work (see bug #406801 for the latest
+ # installment in a riveting series of reports).
+ :
+ # emake -C test check | tee "${T}"/tests
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+}