summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-04-29 12:39:29 +0200
committerSam James <sam@gentoo.org>2022-05-01 20:53:36 +0100
commit305af8ef3a439fedc29673b612d42967c6f85dfe (patch)
tree1a18c048e28804c0573aa9ee3feb50c5d86b29af /dev-libs/intel-compute-runtime
parentdev-util/intel-graphics-compiler: force LLVM12 instead LLVM13 (diff)
downloadgentoo-305af8ef3a439fedc29673b612d42967c6f85dfe.tar.gz
gentoo-305af8ef3a439fedc29673b612d42967c6f85dfe.tar.bz2
gentoo-305af8ef3a439fedc29673b612d42967c6f85dfe.zip
dev-libs/intel-compute-runtime: enable buildins compilation
Signed-off-by: Conrad Kostecki <conikost@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/25252 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/intel-compute-runtime')
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-22.13.22789-r2.ebuild (renamed from dev-libs/intel-compute-runtime/intel-compute-runtime-22.13.22789-r1.ebuild)5
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-22.16.22992-r2.ebuild (renamed from dev-libs/intel-compute-runtime/intel-compute-runtime-22.16.22992-r1.ebuild)5
2 files changed, 4 insertions, 6 deletions
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-22.13.22789-r1.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.13.22789-r2.ebuild
index 62afccf0743e..783bebea072d 100644
--- a/dev-libs/intel-compute-runtime/intel-compute-runtime-22.13.22789-r1.ebuild
+++ b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.13.22789-r2.ebuild
@@ -54,16 +54,15 @@ src_configure() {
-DKHRONOS_GL_HEADERS_DIR="${ESYSROOT}/usr/include"
-DOCL_ICD_VENDORDIR="${EPREFIX}/etc/OpenCL/vendors"
-DSUPPORT_DG1="ON"
+ -Wno-dev
# See https://github.com/intel/intel-graphics-compiler/issues/204
- -DNEO_DISABLE_BUILTINS_COMPILATION="ON"
+ # -DNEO_DISABLE_BUILTINS_COMPILATION="ON"
# If enabled, tests are automatically run during
# the compile phase and we cannot run them because
# they require permissions to access the hardware.
-DSKIP_UNIT_TESTS="1"
-
- -Wno-dev
)
cmake_src_configure
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-22.16.22992-r1.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.16.22992-r2.ebuild
index b121e817268c..f83c1f978986 100644
--- a/dev-libs/intel-compute-runtime/intel-compute-runtime-22.16.22992-r1.ebuild
+++ b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.16.22992-r2.ebuild
@@ -54,16 +54,15 @@ src_configure() {
-DKHRONOS_GL_HEADERS_DIR="${ESYSROOT}/usr/include"
-DOCL_ICD_VENDORDIR="${EPREFIX}/etc/OpenCL/vendors"
-DSUPPORT_DG1="ON"
+ -Wno-dev
# See https://github.com/intel/intel-graphics-compiler/issues/204
- -DNEO_DISABLE_BUILTINS_COMPILATION="ON"
+ # -DNEO_DISABLE_BUILTINS_COMPILATION="ON"
# If enabled, tests are automatically run during
# the compile phase and we cannot run them because
# they require permissions to access the hardware.
-DSKIP_UNIT_TESTS="1"
-
- -Wno-dev
)
cmake_src_configure