summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2023-01-19 15:14:14 +0200
committerJoonas Niilola <juippis@gentoo.org>2023-01-19 17:10:20 +0200
commit8485eadf221e598551f90ac4d08ba31154576cb6 (patch)
treec57482700bc0c4630677ee614db8e0928aa35bd3 /dev-libs/dqlite
parentdev-libs/raft: add 0.17.1 (diff)
downloadgentoo-8485eadf221e598551f90ac4d08ba31154576cb6.tar.gz
gentoo-8485eadf221e598551f90ac4d08ba31154576cb6.tar.bz2
gentoo-8485eadf221e598551f90ac4d08ba31154576cb6.zip
dev-libs/dqlite: add 1.14.0
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/dqlite')
-rw-r--r--dev-libs/dqlite/Manifest1
-rw-r--r--dev-libs/dqlite/dqlite-1.14.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-libs/dqlite/Manifest b/dev-libs/dqlite/Manifest
index 6fa334f8d95d..a3d8ddaf0452 100644
--- a/dev-libs/dqlite/Manifest
+++ b/dev-libs/dqlite/Manifest
@@ -1,2 +1,3 @@
DIST dqlite-1.12.0.tar.gz 181709 BLAKE2B efb35aa9d0c348cd55eb190e27ad155b7d748ccbcb80822f33ce4589d56bc0090f5c0703d769e7090bb8da1b8908cbd73d1076568108661d5b85e55103795a9f SHA512 2a3dc17fcaa0ec2fc5481d3ff57a7bee42c8930f0e6ac7030d51e1a61ae3ce4d7b24f47921b29602a65353c1a51931a82d9af302ee580b19bdce561e6547e940
DIST dqlite-1.13.0.tar.gz 190627 BLAKE2B 02880a112a7b070ee19653b60f19dbb49030b1d0d1bd3671577137ce281fd1af9c135f138d692fcc1c14592972cc9321198b3a2003fa0e81829c8ae462604964 SHA512 da56c622c75dcdc1df814d2b7acfeb08cb046fa7b74691d63575ddb3d30f91b441b8f58cc72466872b4c5e0028706b6505846d8f3d06583be844baefdd85f8a9
+DIST dqlite-1.14.0.tar.gz 190757 BLAKE2B 5304ff10134c7775c4475f77bbe60cc6892cc35c3f2a7b4813743cd27fc1176a1d513d66ebf22b47ed7e83fa833be1408f44f781fbd8200bfd3f4465ea1d6011 SHA512 4305b289903766f00c26e278cce3f761c778b67105a6d7e51e66cc1cbf85564fd41f27689b6895c6f182968d851e10a40d052570d55e22007e9eb5c2929dabd9
diff --git a/dev-libs/dqlite/dqlite-1.14.0.ebuild b/dev-libs/dqlite/dqlite-1.14.0.ebuild
new file mode 100644
index 000000000000..c0cbc911e373
--- /dev/null
+++ b/dev-libs/dqlite/dqlite-1.14.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Embeddable, replicated and fault tolerant SQL engine"
+HOMEPAGE="https://dqlite.io/ https://github.com/canonical/dqlite"
+SRC_URI="https://github.com/canonical/dqlite/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3-with-linking-exception"
+SLOT="0/1.12.0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-db/sqlite:3
+ dev-libs/libuv:=
+ >=dev-libs/raft-0.17.1:="
+DEPEND="${RDEPEND}
+ test? ( >=dev-libs/raft-0.13.0[lz4,test] )"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/dqlite-1.12.0-disable-werror.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-backtrace
+ --disable-debug
+ --disable-sanitize
+ --disable-static
+
+ # Will build a bundled libsqlite3.so.
+ --enable-build-sqlite=no
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}