summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-27 15:51:37 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-27 16:10:03 +0100
commitc6f51f5dc2fe040900180ae160d6b1e0985f17b9 (patch)
tree0728908819a63f8b4a3a59b589c24e8abfc3e4cb /dev-lang
parentvirtual/dist-kernel: Bump to 5.10.11 (diff)
downloadgentoo-c6f51f5dc2fe040900180ae160d6b1e0985f17b9.tar.gz
gentoo-c6f51f5dc2fe040900180ae160d6b1e0985f17b9.tar.bz2
gentoo-c6f51f5dc2fe040900180ae160d6b1e0985f17b9.zip
dev-lang/python: Readd check for failed semaphore checks in 3.7+
Reintroduce the check for failing semaphore checks that result in broken multiprocessing in Python. This check has been mistakenly removed while removing support for USE=-threads. Closes: https://bugs.gentoo.org/496328 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-3.7.9-r2.ebuild6
-rw-r--r--dev-lang/python/python-3.8.7-r1.ebuild6
-rw-r--r--dev-lang/python/python-3.9.1-r1.ebuild6
3 files changed, 18 insertions, 0 deletions
diff --git a/dev-lang/python/python-3.7.9-r2.ebuild b/dev-lang/python/python-3.7.9-r2.ebuild
index 2311ff2ac1b2..e40f7af712be 100644
--- a/dev-lang/python/python-3.7.9-r2.ebuild
+++ b/dev-lang/python/python-3.7.9-r2.ebuild
@@ -167,6 +167,12 @@ src_configure() {
)
OPT="" econf "${myeconfargs[@]}"
+
+ if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
+ eerror "configure has detected that the sem_open function is broken."
+ eerror "Please ensure that /dev/shm is mounted as a tmpfs with mode 1777."
+ die "Broken sem_open function (bug 496328)"
+ fi
}
src_compile() {
diff --git a/dev-lang/python/python-3.8.7-r1.ebuild b/dev-lang/python/python-3.8.7-r1.ebuild
index af74b94b4794..2aee3c922858 100644
--- a/dev-lang/python/python-3.8.7-r1.ebuild
+++ b/dev-lang/python/python-3.8.7-r1.ebuild
@@ -173,6 +173,12 @@ src_configure() {
)
OPT="" econf "${myeconfargs[@]}"
+
+ if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
+ eerror "configure has detected that the sem_open function is broken."
+ eerror "Please ensure that /dev/shm is mounted as a tmpfs with mode 1777."
+ die "Broken sem_open function (bug 496328)"
+ fi
}
src_compile() {
diff --git a/dev-lang/python/python-3.9.1-r1.ebuild b/dev-lang/python/python-3.9.1-r1.ebuild
index 5dbe3f9ffb97..250c0d4af54e 100644
--- a/dev-lang/python/python-3.9.1-r1.ebuild
+++ b/dev-lang/python/python-3.9.1-r1.ebuild
@@ -184,6 +184,12 @@ src_configure() {
)
OPT="" econf "${myeconfargs[@]}"
+
+ if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
+ eerror "configure has detected that the sem_open function is broken."
+ eerror "Please ensure that /dev/shm is mounted as a tmpfs with mode 1777."
+ die "Broken sem_open function (bug 496328)"
+ fi
}
src_compile() {