summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeather Cynede <cynede@gentoo.org>2015-10-29 15:26:09 +0400
committerHeather Cynede <cynede@gentoo.org>2015-10-29 15:26:09 +0400
commit6da348878d177866b9d6dec71d4f3f77df24e2e2 (patch)
treea5220de91cc74778421195cab7fa16d778ca3f21 /dev-lang/fsharp/fsharp-4.0.0.4.ebuild
parentsci-physics/root: Version Bump (diff)
downloadgentoo-6da348878d177866b9d6dec71d4f3f77df24e2e2.tar.gz
gentoo-6da348878d177866b9d6dec71d4f3f77df24e2e2.tar.bz2
gentoo-6da348878d177866b9d6dec71d4f3f77df24e2e2.zip
def-lang/fsharp: bump
Diffstat (limited to 'dev-lang/fsharp/fsharp-4.0.0.4.ebuild')
-rw-r--r--dev-lang/fsharp/fsharp-4.0.0.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-lang/fsharp/fsharp-4.0.0.4.ebuild b/dev-lang/fsharp/fsharp-4.0.0.4.ebuild
new file mode 100644
index 000000000000..40ce3dfad5ed
--- /dev/null
+++ b/dev-lang/fsharp/fsharp-4.0.0.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils mono-env
+
+DESCRIPTION="The F# Compiler"
+HOMEPAGE="https://github.com/fsharp/fsharp"
+SRC_URI="https://github.com/fsharp/fsharp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+MAKEOPTS+=" -j1" #nowarn
+DEPEND=">=dev-lang/mono-3"
+RDEPEND="${DEPEND}"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_install() {
+ autotools-utils_src_install
+}