summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-01-19 17:12:54 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2022-01-20 11:23:03 +0100
commite2f71c912afab2ff3b456033ccea54598e1b118d (patch)
tree94d20fbb5107d227311bfee55a559370a6f5f29b /dev-java/xerial-core
parentdev-java/gson: exclude 1 test if vm_version="1.8" (diff)
downloadgentoo-e2f71c912afab2ff3b456033ccea54598e1b118d.tar.gz
gentoo-e2f71c912afab2ff3b456033ccea54598e1b118d.tar.bz2
gentoo-e2f71c912afab2ff3b456033ccea54598e1b118d.zip
dev-java/xerial-core: EAPI 8, min java 1.8:*
Switching to java-pkg-simple.eclass Closes: https://bugs.gentoo.org/737074 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/23871 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/xerial-core')
-rw-r--r--dev-java/xerial-core/metadata.xml2
-rw-r--r--dev-java/xerial-core/xerial-core-2.0.1-r1.ebuild48
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-java/xerial-core/metadata.xml b/dev-java/xerial-core/metadata.xml
index 779bb7bdf601..7661bbcec79a 100644
--- a/dev-java/xerial-core/metadata.xml
+++ b/dev-java/xerial-core/metadata.xml
@@ -6,6 +6,6 @@
<name>Java</name>
</maintainer>
<upstream>
- <remote-id type="google-code">xerial</remote-id>
+ <remote-id type="github">xerial/xerial-java</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-java/xerial-core/xerial-core-2.0.1-r1.ebuild b/dev-java/xerial-core/xerial-core-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..93fd310af6bb
--- /dev/null
+++ b/dev-java/xerial-core/xerial-core-2.0.1-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri mirror://gentoo/distfiles/4f/xerial-core-2.0.1.tar.bz2 --slot 0 --keywords "~amd64 ~x86" --ebuild xerial-core-2.0.1-r1.ebuild
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="org.xerial:xerial-core:2.0.1"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Core library of the Xerial project."
+HOMEPAGE="https://xerial.org"
+# SRC_URI="https://github.com/xerial/xerial-java/archive/refs/tags/xerial-core-${PV}.tar.gz"
+# Downloading from github is broken
+SRC_URI="https://dev.gentoo.org/~ercpe/distfiles/${CATEGORY}/${PN}/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+S="${WORKDIR}/${P}"
+
+JAVA_SRC_DIR="src/main/java"
+JAVA_RESOURCE_DIRS="src/main/java"
+
+JAVA_TEST_GENTOO_CLASSPATH="junit-4"
+JAVA_TEST_SRC_DIR="src/test/java"
+JAVA_TEST_RESOURCE_DIRS=(
+ "src/test/java"
+ "src/test/resources"
+)
+
+src_test() {
+ # 1) listResoucesInJAR(org.xerial.util.FileResourceTest)
+ # java.lang.AssertionError: at least one resource must be found in org.junit.runner
+ local vm_version="$(java-config -g PROVIDES_VERSION)"
+ if [[ "${vm_version}" != "1.8" ]] ; then
+ JAVA_TEST_EXCLUDES+=( "org.xerial.util.FileResourceTest" )
+ fi
+ java-pkg-simple_src_test
+}