summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2021-06-11 14:17:25 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-08-06 07:49:08 +0200
commit3645e67f7f859bcae2489da898bd758bbadf4cca (patch)
tree03b34b3e767c8d14c086eb076a6d895205332fc1 /dev-java/stringtemplate
parentmedia-libs/raptor: removed obsolete 2.0.15-r3 (diff)
downloadgentoo-3645e67f7f859bcae2489da898bd758bbadf4cca.tar.gz
gentoo-3645e67f7f859bcae2489da898bd758bbadf4cca.tar.bz2
gentoo-3645e67f7f859bcae2489da898bd758bbadf4cca.zip
dev-java/stringtemplate: remove obsolete 3.2.1-r1
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/21018/commits/d84c8819d8e6a3635543a361d4254578c570d45e Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/stringtemplate')
-rw-r--r--dev-java/stringtemplate/stringtemplate-3.2.1-r1.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/dev-java/stringtemplate/stringtemplate-3.2.1-r1.ebuild b/dev-java/stringtemplate/stringtemplate-3.2.1-r1.ebuild
deleted file mode 100644
index 9b357c47389c..000000000000
--- a/dev-java/stringtemplate/stringtemplate-3.2.1-r1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-JAVA_PKG_IUSE="doc source"
-
-inherit epatch java-pkg-2 java-pkg-simple
-
-DESCRIPTION="A Java template engine"
-HOMEPAGE="https://www.stringtemplate.org/"
-SRC_URI="https://github.com/antlr/${PN}3/archive/${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ppc64 x86 ~amd64-linux ~x86-linux ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-CDEPEND=">=dev-java/antlr-2.7.7-r7:0"
-
-RDEPEND="${CDEPEND}
- >=virtual/jre-1.6"
-
-DEPEND="${CDEPEND}
- >=virtual/jdk-1.6
- test? ( >=dev-java/junit-4.11:4 )"
-
-S="${WORKDIR}/${P}"
-JAVA_GENTOO_CLASSPATH="antlr"
-JAVA_SRC_DIR="src"
-
-java_prepare() {
- # https://github.com/antlr/stringtemplate3/pull/3
- epatch "${FILESDIR}/${PV}-test-fixes.patch"
-
- java-pkg_clean
-}
-
-src_compile() {
- local G; for G in action template angle.bracket.template eval group interface; do # from build.xml
- antlr -o src/org/antlr/stringtemplate/language/{,${G}.g} || die
- done
-
- java-pkg-simple_src_compile
-}
-
-src_install() {
- java-pkg-simple_src_install
- dodoc {CHANGES,README}.txt
-}
-
-src_test() {
- cd test || die
- local CP=".:${S}/${PN}.jar:$(java-pkg_getjars junit-4,${JAVA_GENTOO_CLASSPATH})"
-
- local TESTS=$(find * -name "Test*.java")
- TESTS="${TESTS//.java}"
- TESTS="${TESTS//\//.}"
-
- ejavac -classpath "${CP}" $(find -name "*.java")
- ejunit4 -classpath "${CP}" ${TESTS}
-}