summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/json-simple
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/json-simple')
-rw-r--r--dev-java/json-simple/Manifest1
-rw-r--r--dev-java/json-simple/files/build.xml49
-rw-r--r--dev-java/json-simple/files/json-simple-1.1-extra-constructors-from-azureus.patch48
-rw-r--r--dev-java/json-simple/json-simple-1.1.ebuild48
-rw-r--r--dev-java/json-simple/metadata.xml15
5 files changed, 161 insertions, 0 deletions
diff --git a/dev-java/json-simple/Manifest b/dev-java/json-simple/Manifest
new file mode 100644
index 000000000000..45b03f348f6c
--- /dev/null
+++ b/dev-java/json-simple/Manifest
@@ -0,0 +1 @@
+DIST json_simple-1.1-all.zip 44814 SHA256 007568a235ed018142756080e73ec7582af83bd90bbdc227489d186e1529ccf7 SHA512 02a5300456dbe2a1b5331b247ad964237d11d2281b35351f1f7bed6867eaf5bb6fb07ca1a50f87e30cd93221c5119e8b5f6f273357ab5fcfeda164ec119c0404 WHIRLPOOL f1169a8a52349a65469c8ef5ea61fbde469ebd30fdb57b591b0148e2244edb1f78ef99b5d79bc66e4cbfcced3f74436cbbd71e0463aa5b5e6737e81eccea1c82
diff --git a/dev-java/json-simple/files/build.xml b/dev-java/json-simple/files/build.xml
new file mode 100644
index 000000000000..9157aa4b95a6
--- /dev/null
+++ b/dev-java/json-simple/files/build.xml
@@ -0,0 +1,49 @@
+<project name="TimingFramework" default="dist" basedir=".">
+ <description>
+ simple example build file
+ </description>
+ <!-- set global properties for this build -->
+ <property name="src" location="src"/>
+ <property name="build" location="build"/>
+ <property name="dist" location="dist"/>
+ <property name="javadoc" location="javadoc"/>
+
+ <target name="init">
+ <!-- Create the time stamp -->
+ <tstamp/>
+ <!-- Create the build directory structure used by compile -->
+ <mkdir dir="${build}"/>
+ </target>
+
+ <target name="compile" depends="init"
+ description="compile the source " >
+ <!-- Compile the java code from ${src} into ${build} -->
+ <javac srcdir="${src}" destdir="${build}"/>
+ </target>
+
+ <target name="dist" depends="compile"
+ description="generate the distribution" >
+ <!-- Create the distribution directory -->
+ <mkdir dir="${dist}/lib"/>
+
+ <!-- Put everything in ${build} into the MyProject-${DSTAMP}.jar file -->
+ <jar jarfile="${dist}/lib/json-simple.jar" basedir="${build}"/>
+ </target>
+
+ <target name="clean"
+ description="clean up" >
+ <!-- Delete the ${build} and ${dist} directory trees -->
+ <delete dir="${build}"/>
+ <delete dir="${dist}"/>
+ <delete dir="${javadoc}"/>
+ </target>
+
+ <target name="javadoc" description="Produce package javadoc">
+ <javadoc destdir="${javadoc}" >
+ <fileset dir="src" defaultexcludes="yes">
+ <include name="org/json/**"/>
+ </fileset>
+ </javadoc>
+ </target>
+
+</project>
diff --git a/dev-java/json-simple/files/json-simple-1.1-extra-constructors-from-azureus.patch b/dev-java/json-simple/files/json-simple-1.1-extra-constructors-from-azureus.patch
new file mode 100644
index 000000000000..5b45a973e41d
--- /dev/null
+++ b/dev-java/json-simple/files/json-simple-1.1-extra-constructors-from-azureus.patch
@@ -0,0 +1,48 @@
+diff -Nur json_simple-1.1-all/src/org/json/simple/JSONArray.java json_simple-1.1-all_patched//src/org/json/simple/JSONArray.java
+--- json_simple-1.1-all/src/org/json/simple/JSONArray.java 2009-02-01 12:45:34.000000000 +0200
++++ json_simple-1.1-all_patched//src/org/json/simple/JSONArray.java 2011-09-25 11:23:37.398818358 +0300
+@@ -19,6 +19,18 @@
+ public class JSONArray extends ArrayList implements List, JSONAware, JSONStreamAware {
+ private static final long serialVersionUID = 3957988303675231981L;
+
++ public JSONArray() {
++ super();
++ }
++
++ public JSONArray(java.util.Collection arg0) {
++ super(arg0);
++ }
++
++ public JSONArray(int initialCapacity) {
++ super(initialCapacity);
++ }
++
+ /**
+ * Encode a list into JSON text and write it to out.
+ * If this list is also a JSONStreamAware or a JSONAware, JSONStreamAware and JSONAware specific behaviours will be ignored at this top level.
+diff -Nur json_simple-1.1-all/src/org/json/simple/JSONObject.java json_simple-1.1-all_patched//src/org/json/simple/JSONObject.java
+--- json_simple-1.1-all/src/org/json/simple/JSONObject.java 2009-02-01 12:45:34.000000000 +0200
++++ json_simple-1.1-all_patched//src/org/json/simple/JSONObject.java 2011-09-25 11:24:34.815103065 +0300
+@@ -18,6 +18,22 @@
+ public class JSONObject extends HashMap implements Map, JSONAware, JSONStreamAware{
+ private static final long serialVersionUID = -503443796854799292L;
+
++ public JSONObject() {
++ super();
++ }
++
++ public JSONObject(int initialCapacity, float loadFactor) {
++ super(initialCapacity, loadFactor);
++ }
++
++ public JSONObject(int initialCapacity) {
++ super(initialCapacity);
++ }
++
++ public JSONObject(Map arg0) {
++ super(arg0);
++ }
++
+ /**
+ * Encode a map into JSON text and write it to out.
+ * If this map is also a JSONAware or JSONStreamAware, JSONAware or JSONStreamAware specific behaviours will be ignored at this top level.
diff --git a/dev-java/json-simple/json-simple-1.1.ebuild b/dev-java/json-simple/json-simple-1.1.ebuild
new file mode 100644
index 000000000000..bdd58ca69bc0
--- /dev/null
+++ b/dev-java/json-simple/json-simple-1.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+JAVA_PKG_IUSE="source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Simple Java toolkit for JSON"
+HOMEPAGE="http://www.json.org"
+
+MY_PN="${PN/-/_}"
+MY_P="${MY_PN}-${PV}-all"
+SRC_URI="http://json-simple.googlecode.com/files/${MY_P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4
+ test? ( dev-java/ant-junit )
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.4"
+
+S="${WORKDIR}/${MY_P}"
+
+java_prepare() {
+ epatch "${FILESDIR}/${P}-extra-constructors-from-azureus.patch"
+ rm -rv build lib || die
+}
+
+#JAVA_ANT_ENCODING="ISO-8859-1"
+#EANT_BUILD_TARGET="dist"
+
+JAVA_PKG_BSFIX_NAME+=" test.xml"
+
+src_test() {
+ java-pkg_jar-from --into lib junit
+ ANT_TASKS="ant-junit" eant -f test.xml
+}
+
+src_install() {
+ java-pkg_newjar lib/${MY_P/-all/}.jar ${PN}.jar
+ dodoc README.txt AUTHORS.txt ChangeLog.txt || die
+ use source && java-pkg_dosrc src/org
+}
diff --git a/dev-java/json-simple/metadata.xml b/dev-java/json-simple/metadata.xml
new file mode 100644
index 000000000000..71c785e5bc52
--- /dev/null
+++ b/dev-java/json-simple/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription lang="en">Why the Simple Java toolkit (also named as JSON.simple) for JSON?
+ When I use JSON as the data exchange format between the AJAX client and JSP
+ for the first time, what worry me mostly is how to encode Java strings and
+ numbers correctly in the server side so the AJAX client will receive a well
+ formed JSON data. When I looked into the 'JSON in Java' directory in JSON
+ website,I found that wrappers to JSONObject and JSONArray can be simpler,
+ due to the simplicity of JSON itself. So I wrote the JSON.simple package.</longdescription>
+ <upstream>
+ <remote-id type="google-code">json-simple</remote-id>
+ </upstream>
+</pkgmetadata>