summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/commons-logging
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/commons-logging')
-rw-r--r--dev-java/commons-logging/Manifest2
-rw-r--r--dev-java/commons-logging/commons-logging-1.1.1.ebuild74
-rw-r--r--dev-java/commons-logging/commons-logging-1.2.ebuild71
-rw-r--r--dev-java/commons-logging/files/commons-logging-1.1-gentoo.patch27
-rw-r--r--dev-java/commons-logging/files/commons-logging-1.1-manifest8
-rw-r--r--dev-java/commons-logging/files/commons-logging-1.1-servletapi.patch47
-rw-r--r--dev-java/commons-logging/files/commons-logging-1.1.1-gentoo.patch26
-rw-r--r--dev-java/commons-logging/files/commons-logging-1.1.1-manifest8
-rw-r--r--dev-java/commons-logging/files/commons-logging-1.1.1-servletapi.patch46
-rw-r--r--dev-java/commons-logging/files/commons-logging-1.2-gentoo.patch26
-rw-r--r--dev-java/commons-logging/files/commons-logging-1.2-servletapi.patch42
-rw-r--r--dev-java/commons-logging/metadata.xml11
12 files changed, 388 insertions, 0 deletions
diff --git a/dev-java/commons-logging/Manifest b/dev-java/commons-logging/Manifest
new file mode 100644
index 000000000000..69ad80af84a4
--- /dev/null
+++ b/dev-java/commons-logging/Manifest
@@ -0,0 +1,2 @@
+DIST commons-logging-1.1.1-src.tar.gz 190670 SHA256 b49a79fa78ebfae15dc46ae6f0144fee6b94ab608a25518c54609d3419909eb2 SHA512 ccba6cb8078807219dfe4a771c2e6f5569190b52ca00a605a0445b53697d9162c62237fc34ead2960146603b018769f406fe9e47b2eefe0d0fb6ad993c669974 WHIRLPOOL b28ad3dcad851ccbe7fffe9968426b67fb3b6a372de85aa6adb055db5f3eaf621d63f81b9bf74dd6d4958fd681b29272898fc6907b5681a431af0772f876ec16
+DIST commons-logging-1.2-src.tar.gz 188536 SHA256 49665da5a60d033e6dff40fe0a7f9173e886ae859ce6096c1afe34c48b677c81 SHA512 9f3761184950f2f13e85d8bc447709ab8be631dfd231b4f053f8147468db1bf71fb116ddba95e39f4afc4cf28c742e07d40c7a637f28004a60dc13935f9609f9 WHIRLPOOL fe31832404d9071d73fba940021ab664998ffa9867a88c2078918547cc6a23a06339f33f5d74f8b6ea5aaeeb86cd94c0aef6c6195e454a651b8fc492a1a6b5f8
diff --git a/dev-java/commons-logging/commons-logging-1.1.1.ebuild b/dev-java/commons-logging/commons-logging-1.1.1.ebuild
new file mode 100644
index 000000000000..d7ce03301051
--- /dev/null
+++ b/dev-java/commons-logging/commons-logging-1.1.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="1"
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2 java-osgi
+
+DESCRIPTION="The Jakarta-Commons Logging package is an ultra-thin bridge between different logging libraries"
+HOMEPAGE="http://commons.apache.org/logging/"
+SRC_URI="mirror://apache/commons/logging/source/${P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="avalon-logkit log4j servletapi avalon-framework"
+
+COMMON_DEP="
+ avalon-logkit? ( dev-java/avalon-logkit:1.2 )
+ log4j? ( dev-java/log4j:0 )
+ servletapi? ( java-virtuals/servlet-api:2.3 )
+ avalon-framework? ( dev-java/avalon-framework:4.2 )"
+# ATTENTION: Add this when log4j-1.3 is out
+# =dev-java/log4j-1.3*
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.4
+ ${COMMON_DEP}
+ test? ( dev-java/ant-junit:0 )"
+
+S="${WORKDIR}/${P}-src/"
+
+RESTRICT="!servletapi? ( test )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+ # patch to make the build.xml respect no servletapi
+ # TODO file upstream -nichoj
+ epatch "${FILESDIR}/${P}-servletapi.patch"
+
+ # bug 200918
+ java-ant_ignore-system-classes
+
+ # bug #208098
+ echo "jdk.1.4.present=true" > build.properties
+ use log4j && echo "log4j12.jar=$(java-pkg_getjars log4j)" >> build.properties
+ # ATTENTION: Add this when log4j-1.3 is out (check the SLOT)
+ #echo "log4j13.jar=$(java-pkg_getjars log4j-1.3)" > build.properties
+ use avalon-logkit && echo "logkit.jar=$(java-pkg_getjars avalon-logkit-1.2)" >> build.properties
+ use servletapi && echo "servletapi.jar=$(java-pkg_getjar --virtual servlet-api-2.3 servlet.jar)" >> build.properties
+ use avalon-framework && echo "avalon-framework.jar=$(java-pkg_getjars avalon-framework-4.2)" >> build.properties
+ java-pkg_filter-compiler jikes ecj-3.2
+
+ if use test && ! use servletapi; then
+ eerror "Tests need use servletapi, tests not executed"
+ fi
+}
+
+EANT_BUILD_TARGET="compile"
+
+src_install() {
+ java-osgi_newjar-fromfile "target/${P}-SNAPSHOT.jar" "${FILESDIR}/${P}-manifest" "Apache Commons Logging"
+ java-pkg_newjar target/${PN}-api-${PV}-SNAPSHOT.jar ${PN}-api.jar
+ java-pkg_newjar target/${PN}-adapters-${PV}-SNAPSHOT.jar ${PN}-adapters.jar
+
+ dodoc RELEASE-NOTES.txt || die
+ dohtml PROPOSAL.html STATUS.html || die
+ use doc && java-pkg_dojavadoc target/docs/
+ use source && java-pkg_dosrc src/java/org
+}
diff --git a/dev-java/commons-logging/commons-logging-1.2.ebuild b/dev-java/commons-logging/commons-logging-1.2.ebuild
new file mode 100644
index 000000000000..e1edb14bb5de
--- /dev/null
+++ b/dev-java/commons-logging/commons-logging-1.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2 java-osgi
+
+DESCRIPTION="The Jakarta-Commons Logging package is an ultra-thin bridge between different logging libraries"
+HOMEPAGE="http://commons.apache.org/logging/"
+SRC_URI="mirror://apache/commons/logging/source/${P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="avalon-logkit log4j servletapi avalon-framework"
+
+COMMON_DEP="
+ avalon-logkit? ( dev-java/avalon-logkit:1.2 )
+ log4j? ( dev-java/log4j:0 )
+ servletapi? ( java-virtuals/servlet-api:2.3 )
+ avalon-framework? ( dev-java/avalon-framework:4.2 )"
+# ATTENTION: Add this when log4j-1.3 is out
+# =dev-java/log4j-1.3*
+RDEPEND=">=virtual/jre-1.6
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.6
+ ${COMMON_DEP}
+ test? ( dev-java/ant-junit:0 )"
+
+S="${WORKDIR}/${P}-src/"
+
+RESTRICT="!servletapi? ( test )"
+
+java_prepare() {
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+ # patch to make the build.xml respect no servletapi
+ # TODO file upstream -nichoj
+ epatch "${FILESDIR}/${P}-servletapi.patch"
+
+ # bug 200918
+ java-ant_ignore-system-classes
+
+ # bug #208098
+ echo "jdk.1.4.present=true" > build.properties
+ use log4j && echo "log4j12.jar=$(java-pkg_getjars log4j)" >> build.properties
+ # ATTENTION: Add this when log4j-1.3 is out (check the SLOT)
+ #echo "log4j13.jar=$(java-pkg_getjars log4j-1.3)" > build.properties
+ use avalon-logkit && echo "logkit.jar=$(java-pkg_getjars avalon-logkit-1.2)" >> build.properties
+ use servletapi && echo "servletapi.jar=$(java-pkg_getjar --virtual servlet-api-2.3 servlet.jar)" >> build.properties
+ use avalon-framework && echo "avalon-framework.jar=$(java-pkg_getjars avalon-framework-4.2)" >> build.properties
+ java-pkg_filter-compiler jikes ecj-3.2
+
+ if use test && ! use servletapi; then
+ eerror "Tests need use servletapi, tests not executed"
+ fi
+}
+
+EANT_BUILD_TARGET="compile"
+
+src_install() {
+ java-osgi_newjar "target/${P}.jar" "org.apache.commons.logging" "Apache Commons Logging" "org.apache.commons.logging;version=\"${PV}\", org.apache.commons.logging.impl;version=\"${PV}\""
+ java-pkg_newjar target/${PN}-api-${PV}.jar ${PN}-api.jar
+ java-pkg_newjar target/${PN}-adapters-${PV}.jar ${PN}-adapters.jar
+
+ dodoc RELEASE-NOTES.txt || die
+ dohtml PROPOSAL.html || die
+ use doc && java-pkg_dojavadoc target/docs/
+ use source && java-pkg_dosrc src/main/java/org
+}
diff --git a/dev-java/commons-logging/files/commons-logging-1.1-gentoo.patch b/dev-java/commons-logging/files/commons-logging-1.1-gentoo.patch
new file mode 100644
index 000000000000..06ac54cdb79f
--- /dev/null
+++ b/dev-java/commons-logging/files/commons-logging-1.1-gentoo.patch
@@ -0,0 +1,27 @@
+--- build.xml.original 2006-10-01 18:15:11.000000000 +0200
++++ build.xml 2006-10-01 18:36:46.000000000 +0200
+@@ -772,5 +772,23 @@
+ One or more unit tests failed.
+ </fail>
+ </target>
+-
++ <target name="javadoc" description="o Generate javadoc" depends="">
++ <mkdir dir="${build.home}/docs">
++ </mkdir>
++ <tstamp>
++ <format pattern="2001-yyyy" property="year">
++ </format>
++ </tstamp>
++ <property name="copyright" value="Copyright &amp;copy; The Apache Software Foundation. All Rights Reserved.">
++ </property>
++ <property name="title" value="Logging 1.1 API">
++ </property>
++ <javadoc use="true" private="true" destdir="${build.home}/docs" author="true" version="true" sourcepath="src/java" packagenames="org.apache.commons.logging.*">
++ <classpath>
++ <path refid="javadoc.classpath">
++ </path>
++ </classpath>
++ </javadoc>
++ </target>
++
+ </project>
diff --git a/dev-java/commons-logging/files/commons-logging-1.1-manifest b/dev-java/commons-logging/files/commons-logging-1.1-manifest
new file mode 100644
index 000000000000..09d24e8e88a7
--- /dev/null
+++ b/dev-java/commons-logging/files/commons-logging-1.1-manifest
@@ -0,0 +1,8 @@
+Manifest-Version: 1.0
+Bundle-ManifestVersion: 2
+Bundle-Name: %bundleName
+Bundle-Vendor: %vendorName
+Bundle-Localization: plugin
+Bundle-SymbolicName: org.apache.commons.logging
+Bundle-Version: 1.1
+Export-Package: org.apache.commons.logging;version="1.1",org.apache.commons.logging.impl;version="1.1"
diff --git a/dev-java/commons-logging/files/commons-logging-1.1-servletapi.patch b/dev-java/commons-logging/files/commons-logging-1.1-servletapi.patch
new file mode 100644
index 000000000000..0045cd195b0f
--- /dev/null
+++ b/dev-java/commons-logging/files/commons-logging-1.1-servletapi.patch
@@ -0,0 +1,47 @@
+diff -ru commons-logging-1.1-src/build.xml commons-logging-1.1-src-patched/build.xml
+--- commons-logging-1.1-src/build.xml 2006-05-09 17:45:08.000000000 -0400
++++ commons-logging-1.1-src-patched/build.xml 2006-10-20 01:16:51.000000000 -0400
+@@ -274,6 +274,10 @@
+ classpathref="compile.classpath"
+ classname="org.apache.log.Logger"/>
+
++ <available property="servletapi.present"
++ classpathref="compile.classpath"
++ classname="javax.servlet.ServletContextEvent"/>
++
+ <available property="avalon-framework.present"
+ classpathref="compile.classpath"
+ classname="org.apache.avalon.framework.logger.Logger"/>
+@@ -303,6 +307,13 @@
+ -->
+ </target>
+
++ <target name="servletapi-warning" unless='servletapi.present' depends="init,discovery">
++ <echo>
++ *** WARNING ***
++ ServletAPI not found: Cannot Build ServletContextCleaner
++ </echo>
++ </target>
++
+ <target name="logkit-warning" unless='logkit.present' depends='init,discovery'>
+ <echo>
+ *** WARNING ***
+@@ -332,7 +343,7 @@
+ </target>
+
+ <target name='warning'
+- depends='log4j12-warning,log4j13-warning,logkit-warning,jdk1.4-warning,avalon-framework-warning,compile-1.4'/>
++ depends='log4j12-warning,log4j13-warning,logkit-warning,jdk1.4-warning,avalon-framework-warning,servletapi-warning,compile-1.4'/>
+
+ <target name="compile-only"
+ depends="prepare,discovery,warning,show-lib-presence,compile-non-log4j,compile-log4j12,compile-log4j13,build-jar"/>
+@@ -360,6 +371,8 @@
+
+ <exclude name="org/apache/commons/logging/impl/Log4J*.java"/>
+
++ <exclude name="org/apache/commons/logging/impl/ServletContextCleaner.java"
++ unless="servletapi.present"/>
+ <exclude name="org/apache/commons/logging/impl/Jdk13LumberjackLogger.java"
+ unless="jdk.1.4.present"/>
+ <exclude name="org/apache/commons/logging/impl/Jdk14Logger.java"
+Only in commons-logging-1.1-src-patched/: target
diff --git a/dev-java/commons-logging/files/commons-logging-1.1.1-gentoo.patch b/dev-java/commons-logging/files/commons-logging-1.1.1-gentoo.patch
new file mode 100644
index 000000000000..6d468735d0e7
--- /dev/null
+++ b/dev-java/commons-logging/files/commons-logging-1.1.1-gentoo.patch
@@ -0,0 +1,26 @@
+--- build.xml.orig 2008-02-06 16:09:59.000000000 +0100
++++ build.xml 2008-02-06 16:10:48.000000000 +0100
+@@ -785,4 +785,23 @@
+ </fail>
+ </target>
+
++ <target name="javadoc" description="o Generate javadoc" depends="">
++ <mkdir dir="${build.home}/docs">
++ </mkdir>
++ <tstamp>
++ <format pattern="2001-yyyy" property="year">
++ </format>
++ </tstamp>
++ <property name="copyright" value="Copyright &amp;copy; The Apache Software Foundation. All Rights Reserved.">
++ </property>
++ <property name="title" value="Logging 1.1 API">
++ </property>
++ <javadoc use="true" private="true" destdir="${build.home}/docs" author="true" version="true" sourcepath="src/java" packagenames="org.apache.commons.logging.*">
++ <classpath>
++ <path refid="javadoc.classpath">
++ </path>
++ </classpath>
++ </javadoc>
++ </target>
++
+ </project>
diff --git a/dev-java/commons-logging/files/commons-logging-1.1.1-manifest b/dev-java/commons-logging/files/commons-logging-1.1.1-manifest
new file mode 100644
index 000000000000..382da7a047e5
--- /dev/null
+++ b/dev-java/commons-logging/files/commons-logging-1.1.1-manifest
@@ -0,0 +1,8 @@
+Manifest-Version: 1.0
+Bundle-ManifestVersion: 2
+Bundle-Name: %bundleName
+Bundle-Vendor: %vendorName
+Bundle-Localization: plugin
+Bundle-SymbolicName: org.apache.commons.logging
+Bundle-Version: 1.1.1
+Export-Package: org.apache.commons.logging;version="1.1.1",org.apache.commons.logging.impl;version="1.1.1"
diff --git a/dev-java/commons-logging/files/commons-logging-1.1.1-servletapi.patch b/dev-java/commons-logging/files/commons-logging-1.1.1-servletapi.patch
new file mode 100644
index 000000000000..2c29fa544019
--- /dev/null
+++ b/dev-java/commons-logging/files/commons-logging-1.1.1-servletapi.patch
@@ -0,0 +1,46 @@
+--- build.xml.orig2 2008-02-06 16:13:45.000000000 +0100
++++ build.xml 2008-02-06 16:16:48.000000000 +0100
+@@ -276,6 +276,11 @@
+ classpathref="compile.classpath"
+ classname="org.apache.log.Logger"/>
+
++ <available property="servletapi.present"
++ classpathref="compile.classpath"
++ classname="javax.servlet.ServletContextEvent"/>
++
++
+ <available property="avalon-framework.present"
+ classpathref="compile.classpath"
+ classname="org.apache.avalon.framework.logger.Logger"/>
+@@ -312,6 +317,13 @@
+ </echo>
+ </target>
+
++ <target name="servletapi-warning" unless='servletapi.present' depends="init,discovery">
++ <echo>
++ *** WARNING ***
++ ServletAPI not found: Cannot Build ServletContextCleaner
++ </echo>
++ </target>
++
+ <target name="avalon-framework-warning" unless='avalon-framework.present' depends='init,discovery'>
+ <echo>
+ *** WARNING ***
+@@ -334,7 +346,7 @@
+ </target>
+
+ <target name='warning'
+- depends='log4j12-warning,log4j13-warning,logkit-warning,jdk1.4-warning,avalon-framework-warning,compile-1.4'/>
++ depends='log4j12-warning,log4j13-warning,logkit-warning,jdk1.4-warning,avalon-framework-warning,servletapi-warning,compile-1.4'/>
+
+ <target name="compile-only"
+ depends="prepare,discovery,warning,show-lib-presence,compile-non-log4j,compile-log4j12,compile-log4j13,build-jar"/>
+@@ -362,6 +374,8 @@
+
+ <exclude name="org/apache/commons/logging/impl/Log4J*.java"/>
+
++ <exclude name="org/apache/commons/logging/impl/ServletContextCleaner.java"
++ unless="servletapi.present"/>
+ <exclude name="org/apache/commons/logging/impl/Jdk13LumberjackLogger.java"
+ unless="jdk.1.4.present"/>
+ <exclude name="org/apache/commons/logging/impl/Jdk14Logger.java"
diff --git a/dev-java/commons-logging/files/commons-logging-1.2-gentoo.patch b/dev-java/commons-logging/files/commons-logging-1.2-gentoo.patch
new file mode 100644
index 000000000000..f359e8e224bf
--- /dev/null
+++ b/dev-java/commons-logging/files/commons-logging-1.2-gentoo.patch
@@ -0,0 +1,26 @@
+--- a/build.xml 2013-05-16 22:04:22.000000000 +0200
++++ b/build.xml 2013-12-25 23:58:47.447266535 +0100
+@@ -773,4 +773,23 @@
+ </fail>
+ </target>
+
++ <target depends="" name="javadoc" description="o Generate javadoc" >
++ <mkdir dir="${build.home}/docs" >
++ </mkdir>
++ <tstamp >
++ <format pattern="2001-yyyy" property="year" >
++ </format>
++ </tstamp>
++ <property name="copyright" value="Copyright &amp;copy; The Apache Software Foundation. All Rights Reserved." >
++ </property>
++ <property name="title" value="Logging 1.1 API" >
++ </property>
++ <javadoc use="true" author="true" sourcepath="src/main/java" destdir="${build.home}/docs" version="true" private="true" packagenames="org.apache.commons.logging.*" >
++ <classpath >
++ <path refid="javadoc.classpath" >
++ </path>
++ </classpath>
++ </javadoc>
++ </target>
++
+ </project>
diff --git a/dev-java/commons-logging/files/commons-logging-1.2-servletapi.patch b/dev-java/commons-logging/files/commons-logging-1.2-servletapi.patch
new file mode 100644
index 000000000000..96299c131f1b
--- /dev/null
+++ b/dev-java/commons-logging/files/commons-logging-1.2-servletapi.patch
@@ -0,0 +1,42 @@
+--- a/build.xml 2013-12-26 00:00:51.019721667 +0100
++++ b/build.xml 2013-12-26 00:22:27.616511976 +0100
+@@ -279,6 +279,8 @@
+ classpathref="compile.classpath"
+ classname="org.apache.log.Logger"/>
+
++ <available classname="javax.servlet.ServletContextEvent" property="servletapi.present" classpathref="compile.classpath" ignoresystemclasses="true" ></available>
++
+ <available property="avalon-framework.present"
+ classpathref="compile.classpath"
+ classname="org.apache.avalon.framework.logger.Logger"/>
+@@ -315,6 +317,13 @@
+ </echo>
+ </target>
+
++ <target depends="init,discovery" unless="servletapi.present" name="servletapi-warning" >
++ <echo >
++ *** WARNING ***
++ ServletAPI not found: Cannot Build ServletContextCleaner
++ </echo>
++ </target>
++
+ <target name="avalon-framework-warning" unless='avalon-framework.present' depends='init,discovery'>
+ <echo>
+ *** WARNING ***
+@@ -337,7 +346,7 @@
+ </target>
+
+ <target name='warning'
+- depends='log4j12-warning,log4j13-warning,logkit-warning,jdk1.4-warning,avalon-framework-warning,compile-1.4'/>
++ depends='log4j12-warning,log4j13-warning,logkit-warning,jdk1.4-warning,avalon-framework-warning,servletapi-warning,compile-1.4'/>
+
+ <target name="compile-only"
+ depends="prepare,discovery,warning,show-lib-presence,compile-non-log4j,compile-log4j12,compile-log4j13,build-jar"/>
+@@ -365,6 +374,7 @@
+
+ <exclude name="org/apache/commons/logging/impl/Log4J*.java"/>
+
++ <exclude unless="servletapi.present" name="org/apache/commons/logging/impl/ServletContextCleaner.java" ></exclude>
+ <exclude name="org/apache/commons/logging/impl/Jdk13LumberjackLogger.java"
+ unless="jdk.1.4.present"/>
+ <exclude name="org/apache/commons/logging/impl/Jdk14Logger.java"
diff --git a/dev-java/commons-logging/metadata.xml b/dev-java/commons-logging/metadata.xml
new file mode 100644
index 000000000000..47d5d795f1ab
--- /dev/null
+++ b/dev-java/commons-logging/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <use>
+ <flag name="avalon-framework">Add optional support for avalon-framework</flag>
+ <flag name="avalon-logkit">Add optional support for avalon-logkit</flag>
+ <flag name="log4j">Add optional support for log4j</flag>
+ <flag name="servletapi">Add optional support for servletapi</flag>
+ </use>
+</pkgmetadata>