summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-09-11 10:48:11 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2016-09-11 11:01:32 +0100
commitba9927d54e89114c3ed6fda3c8f6147671a4035d (patch)
tree53a95249551e79c168969a46dd064e1f27460eca /dev-haskell
parentdev-haskell/idiii: ID3 parser/generator library, a depend of app-forensics/qu... (diff)
downloadgentoo-ba9927d54e89114c3ed6fda3c8f6147671a4035d.tar.gz
gentoo-ba9927d54e89114c3ed6fda3c8f6147671a4035d.tar.bz2
gentoo-ba9927d54e89114c3ed6fda3c8f6147671a4035d.zip
dev-haskell/bitwise: multidimentional bit arrays, a depend of app-forensics/quickfuzz
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/bitwise/Manifest1
-rw-r--r--dev-haskell/bitwise/bitwise-0.1.1.1.ebuild33
-rw-r--r--dev-haskell/bitwise/metadata.xml52
3 files changed, 86 insertions, 0 deletions
diff --git a/dev-haskell/bitwise/Manifest b/dev-haskell/bitwise/Manifest
new file mode 100644
index 000000000000..2ce8f28880a0
--- /dev/null
+++ b/dev-haskell/bitwise/Manifest
@@ -0,0 +1 @@
+DIST bitwise-0.1.1.1.tar.gz 17107 SHA256 cde04615108c8e1e4b9f3a6fd7115b6fe40068385489fc5fc3d41e3700d69486 SHA512 f599411c6ce68a0ac71045ade891ae9c70a2b94b79285cdbac9e694bf227df5f0e65f115321ac62ac2878232aa91b5a6a376ae43654671fda0de2f9b0b65c70e WHIRLPOOL 6e161561d8a34400b93763b699a7af5fa8a7f5a10d097a2ae6cd6365f12d8e12c253fc316b11e63b0ff4b6c6fffdca0f2d399439c4babe0af3e97f56563c3d91
diff --git a/dev-haskell/bitwise/bitwise-0.1.1.1.ebuild b/dev-haskell/bitwise/bitwise-0.1.1.1.ebuild
new file mode 100644
index 000000000000..4cee11ce3c00
--- /dev/null
+++ b/dev-haskell/bitwise/bitwise-0.1.1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="fast multi-dimensional unboxed bit packed Bool arrays"
+HOMEPAGE="http://code.mathr.co.uk/bitwise"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.9.2
+ test? ( >=dev-haskell/quickcheck-2.4 )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'QuickCheck >= 2.4 && < 2.9' 'QuickCheck >= 2.4'
+}
diff --git a/dev-haskell/bitwise/metadata.xml b/dev-haskell/bitwise/metadata.xml
new file mode 100644
index 000000000000..4f0bc14cf689
--- /dev/null
+++ b/dev-haskell/bitwise/metadata.xml
@@ -0,0 +1,52 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Unboxed multidimensional bit packed Bool arrays with fast aggregate
+ operations based on lifting Bool operations to bitwise operations.
+
+ There are many other bit packed structures out there, but none met
+ all of these requirements:
+
+ (1) unboxed bit packed Bool array,
+
+ (2) multi-dimensional indexing,
+
+ (3) fast (de)serialization, or interoperable with foreign code,
+
+ (4) fast aggregate operations (fold, map, zip).
+
+ Quick tour of the bitwise library:
+
+ [Data.Bits.Bitwise] Lift boolean operations on &#39;Bool&#39; to bitwise
+ operations on &#39;Data.Bits.Bits&#39;.
+
+ [Data.Array.BitArray] Immutable bit arrays.
+
+ [Data.Array.BitArray.ST] Mutable bit arrays in &#39;Control.Monad.ST.ST&#39;.
+
+ [Data.Array.BitArray.IO] Mutable bit arrays in &#39;IO&#39;.
+
+ [Data.Array.BitArray.ByteString] (De)serialization.
+
+ [Codec.Image.PBM] Portable bitmap monochrome 2D image format.
+
+ Very rough performance benchmarks:
+
+ * immutable random access single bit reads:
+ @BitArray ix@ is about 40% slower than @UArray ix Bool@,
+
+ * &#39;Control.Monad.ST.ST&#39; mutable random access single bit reads:
+ @STBitArray s ix@ is about the same as @STUArray s ix Bool@,
+
+ * immutable map @Bool -&gt; Bool@:
+ @BitArray ix@ is about 85x faster than @UArray ix Bool@,
+
+ * immutable zipWith @Bool -&gt; Bool -&gt; Bool@:
+ @BitArray ix@ is about 1300x faster than @UArray ix Bool@.
+ </longdescription>
+</pkgmetadata>