summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-games/flinker
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-games/flinker')
-rw-r--r--dev-games/flinker/Manifest1
-rw-r--r--dev-games/flinker/flinker-1.72.ebuild37
-rw-r--r--dev-games/flinker/metadata.xml10
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-games/flinker/Manifest b/dev-games/flinker/Manifest
new file mode 100644
index 000000000000..d26713349b43
--- /dev/null
+++ b/dev-games/flinker/Manifest
@@ -0,0 +1 @@
+DIST flgba.zip 41380 SHA256 92b7e0f4c61f85b12c473701ad0b09e68de6d60bbe3f4183ec91b500b53eb92c SHA512 36e9542d5588c655b3001f7515cca487d0f820cbc7e8613afcda5dbcd1b9c48e4d2f9c3c8b755a466eb421ea6198102408494006c14e3ea3e6a22c2e0da6bb1c WHIRLPOOL 273b1c271b9f3acbbd7a820ce18cfa1f5fed98cc0699dc1575cfa71c5c94a37d34e5102158b18b8fc580cac1bcd71db566dcb7d2fb6368892c1ec16daf311995
diff --git a/dev-games/flinker/flinker-1.72.ebuild b/dev-games/flinker/flinker-1.72.ebuild
new file mode 100644
index 000000000000..e14e58a5579c
--- /dev/null
+++ b/dev-games/flinker/flinker-1.72.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="GBA cart writing utility by Jeff Frohwein"
+HOMEPAGE="http://www.devrs.com/gba/software.php#misc"
+SRC_URI="http://www.devrs.com/gba/files/flgba.zip"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}
+
+src_prepare() {
+ sed -i \
+ -e '/unistd/s:^//::' \
+ -e 's:asm/io.h:sys/io.h:' \
+ fl.c || die
+ echo >> fl.c
+ echo >> cartlib.c
+}
+src_compile() {
+ $(tc-getCC) ${LDFLAGS} -o FLinker ${CFLAGS} fl.c || die
+}
+
+src_install() {
+ dobin FLinker
+ dodoc readme
+}
diff --git a/dev-games/flinker/metadata.xml b/dev-games/flinker/metadata.xml
new file mode 100644
index 000000000000..084eec06ea85
--- /dev/null
+++ b/dev-games/flinker/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+Here's a dos/linux program (with src) that allows you program a Visoly flash
+cart (up to 50% faster than official software) or an official Nintendo flash
+cart (2-3 times faster than official hw/sw) by using the Visoly flash linker.
+</longdescription>
+</pkgmetadata>