summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-08-20 11:25:10 +0300
committerViorel Munteanu <ceamac@gentoo.org>2023-08-20 12:32:31 +0300
commit15974072b734f58a9169e8f6757c6b4f17fd14e8 (patch)
tree73da0d66d1cb1ac8f27914ed3e0fdb7c9b67410f /dev-embedded
parentapp-portage/flaggie: Remove old (diff)
downloadgentoo-15974072b734f58a9169e8f6757c6b4f17fd14e8.tar.gz
gentoo-15974072b734f58a9169e8f6757c6b4f17fd14e8.tar.bz2
gentoo-15974072b734f58a9169e8f6757c6b4f17fd14e8.zip
dev-embedded/sdcc: fix compilation of live version
Update patches, create an empty directory. Closes: https://bugs.gentoo.org/911463 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/sdcc/files/sdcc-4.3.2-override-override.patch62
-rw-r--r--dev-embedded/sdcc/sdcc-9999.ebuild5
2 files changed, 65 insertions, 2 deletions
diff --git a/dev-embedded/sdcc/files/sdcc-4.3.2-override-override.patch b/dev-embedded/sdcc/files/sdcc-4.3.2-override-override.patch
new file mode 100644
index 000000000000..8a0e587f5f6b
--- /dev/null
+++ b/dev-embedded/sdcc/files/sdcc-4.3.2-override-override.patch
@@ -0,0 +1,62 @@
+https://bugs.gentoo.org/911463
+
+--- a/support/sdbinutils/config/override.m4
++++ b/support/sdbinutils/config/override.m4
+@@ -27,27 +27,6 @@
+ m4_copy_force([_AC_PREREQ], [AC_PREREQ])
+
+
+-dnl Ensure exactly this Autoconf version is used
+-m4_ifndef([_GCC_AUTOCONF_VERSION],
+- [m4_define([_GCC_AUTOCONF_VERSION], [2.69])])
+-
+-dnl Test for the exact version when AC_INIT is expanded.
+-dnl This allows one to update the tree in steps (for testing)
+-dnl by putting
+-dnl m4_define([_GCC_AUTOCONF_VERSION], [X.Y])
+-dnl in configure.ac before AC_INIT,
+-dnl without rewriting this file.
+-dnl Or for updating the whole tree at once with the definition above.
+-AC_DEFUN([_GCC_AUTOCONF_VERSION_CHECK],
+-[m4_if(m4_defn([_GCC_AUTOCONF_VERSION]),
+- m4_defn([m4_PACKAGE_VERSION]), [],
+- [m4_fatal([Please use exactly Autoconf ]_GCC_AUTOCONF_VERSION[ instead of ]m4_defn([m4_PACKAGE_VERSION])[.])])
+-])
+-m4_define([AC_INIT], m4_defn([AC_INIT])[
+-_GCC_AUTOCONF_VERSION_CHECK
+-])
+-
+-
+ dnl Ensure we do not use a buggy M4.
+ m4_if(m4_index([..wi.d.], [.d.]), [-1],
+ [m4_fatal(m4_do([m4 with buggy strstr detected. Please install
+--- a/support/cpp/config/override.m4
++++ b/support/cpp/config/override.m4
+@@ -27,27 +27,6 @@
+ m4_copy_force([_AC_PREREQ], [AC_PREREQ])
+
+
+-dnl Ensure exactly this Autoconf version is used
+-m4_ifndef([_GCC_AUTOCONF_VERSION],
+- [m4_define([_GCC_AUTOCONF_VERSION], [2.69])])
+-
+-dnl Test for the exact version when AC_INIT is expanded.
+-dnl This allows to update the tree in steps (for testing)
+-dnl by putting
+-dnl m4_define([_GCC_AUTOCONF_VERSION], [X.Y])
+-dnl in configure.ac before AC_INIT,
+-dnl without rewriting this file.
+-dnl Or for updating the whole tree at once with the definition above.
+-AC_DEFUN([_GCC_AUTOCONF_VERSION_CHECK],
+-[m4_if(m4_defn([_GCC_AUTOCONF_VERSION]),
+- m4_defn([m4_PACKAGE_VERSION]), [],
+- [m4_fatal([Please use exactly Autoconf ]_GCC_AUTOCONF_VERSION[ instead of ]m4_defn([m4_PACKAGE_VERSION])[.])])
+-])
+-m4_define([AC_INIT], m4_defn([AC_INIT])[
+-_GCC_AUTOCONF_VERSION_CHECK
+-])
+-
+-
+ dnl Ensure we do not use a buggy M4.
+ m4_if(m4_index([..wi.d.], [.d.]), [-1],
+ [m4_fatal(m4_do([m4 with buggy strstr detected. Please install
diff --git a/dev-embedded/sdcc/sdcc-9999.ebuild b/dev-embedded/sdcc/sdcc-9999.ebuild
index dc4655403f3d..f2689c566ba0 100644
--- a/dev-embedded/sdcc/sdcc-9999.ebuild
+++ b/dev-embedded/sdcc/sdcc-9999.ebuild
@@ -62,8 +62,7 @@ DEPEND="
dev-util/gperf
"
PATCHES=(
- "${FILESDIR}"/sdcc-3.8.0-override-override.patch
- "${FILESDIR}"/sdcc-4.2.0-link-tinfo.patch
+ "${FILESDIR}"/sdcc-4.3.2-override-override.patch
)
src_prepare() {
@@ -84,6 +83,8 @@ src_prepare() {
# Make sure timestamps don't get messed up.
[[ ${PV} == "9999" ]] && find "${S}" -type f -exec touch -r . {} +
+ mkdir -p support/sdbinutils/bfd/doc || die
+
default
eautoreconf