summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-12 20:26:38 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-13 10:42:34 +0100
commit60fbd492caf88f5a269085723024ce37f3e36d50 (patch)
tree8fd4636502a6c1021c7bc11826e2ed12dd1d4684 /dev-debug
parentMove {dev-util → dev-debug}/lldb (diff)
downloadgentoo-60fbd492caf88f5a269085723024ce37f3e36d50.tar.gz
gentoo-60fbd492caf88f5a269085723024ce37f3e36d50.tar.bz2
gentoo-60fbd492caf88f5a269085723024ce37f3e36d50.zip
Move {dev-util → dev-debug}/cgdb
Signed-off-by: Michał Górny <mgorny@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/34774 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-debug')
-rw-r--r--dev-debug/cgdb/Manifest2
-rw-r--r--dev-debug/cgdb/cgdb-0.7.1.ebuild72
-rw-r--r--dev-debug/cgdb/cgdb-0.8.0.ebuild69
-rw-r--r--dev-debug/cgdb/cgdb-9999.ebuild69
-rw-r--r--dev-debug/cgdb/files/cgdb-0.7.1-respect-AR.patch32
-rw-r--r--dev-debug/cgdb/files/cgdb-0.8.0-ar.patch18
-rw-r--r--dev-debug/cgdb/files/cgdb-9999-ar.patch16
-rw-r--r--dev-debug/cgdb/files/cgdb-test.patch55
-rw-r--r--dev-debug/cgdb/metadata.xml9
9 files changed, 342 insertions, 0 deletions
diff --git a/dev-debug/cgdb/Manifest b/dev-debug/cgdb/Manifest
new file mode 100644
index 000000000000..38abca18f809
--- /dev/null
+++ b/dev-debug/cgdb/Manifest
@@ -0,0 +1,2 @@
+DIST cgdb-0.7.1.tar.gz 314768 BLAKE2B 767a57d071fa4e3c75d231a1ec879d871669fcda9c733d157d380fa525dd321f1deb68d7ef7f424b3f36a115043a0a0faae271f24746f934e288ba7d9a4e7fa1 SHA512 050c7bad963d51c1a2cb309530319ca77e9d236f419fb0abac4ab5030ff1068d799fa626959a8b3036321711de98bddf40d264bf9367ff5697075e30ca8168c6
+DIST cgdb-0.8.0.tar.gz 328281 BLAKE2B 60e577dd5f8363b91da33136a9ffd911581e9cea4cdc1d0fcd338e0a761a26921e6edf6298c619b8d0eb1486449843457b2c5370a395a8c49fed5382a60e63a2 SHA512 e2b653db472de2014402dae6d13953ab811526a47ad5d7a05e34cfba09f44d6fea6b19304b9205ff0e2ac9549ffa5818f4282d7c03293b6c0ca9d563f9ae89e1
diff --git a/dev-debug/cgdb/cgdb-0.7.1.ebuild b/dev-debug/cgdb/cgdb-0.7.1.ebuild
new file mode 100644
index 000000000000..970c6382192f
--- /dev/null
+++ b/dev-debug/cgdb/cgdb-0.7.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="
+ https://github.com/cgdb/cgdb.git
+ git@github.com:cgdb/cgdb.git"
+else
+ SRC_URI="https://github.com/cgdb/cgdb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
+fi
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="A curses front-end for GDB, the GNU debugger"
+HOMEPAGE="https://cgdb.github.io/"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ sys-libs/ncurses:0=
+ sys-libs/readline:0="
+
+BDEPEND="
+ test? (
+ dev-util/dejagnu
+ app-misc/dtach
+ )"
+
+RDEPEND="
+ ${DEPEND}
+ dev-debug/gdb"
+
+DOCS=( AUTHORS ChangeLog FAQ INSTALL NEWS README.md )
+
+PATCHES=(
+ # Bugs: #730138, #678006, #630512
+ "${FILESDIR}/${PN}-test.patch"
+ # Bug: #724256
+ "${FILESDIR}/${P}-respect-AR.patch"
+)
+
+src_prepare() {
+ default
+ cp configure.{init,ac} || die "cp failed"
+ AT_M4DIR="config" eautoreconf
+}
+
+multilib_src_test() {
+ # Tests need an interactive shell, #654986
+
+ # real-time output of the log ;-)
+ touch "${T}/dtach-test.log" || die
+ tail -f "${T}/dtach-test.log" &
+ local tail_pid=${!}
+
+ nonfatal dtach -N "${T}/dtach.sock" \
+ bash -c 'emake check &> "${T}"/dtach-test.log; echo ${?} > "${T}"/dtach-test.out'
+
+ kill "${tail_pid}"
+ [[ -f ${T}/dtach-test.out ]] || die "Unable to run tests"
+ [[ $(<"${T}"/dtach-test.out) == 0 ]] || die "Tests failed"
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf
+}
diff --git a/dev-debug/cgdb/cgdb-0.8.0.ebuild b/dev-debug/cgdb/cgdb-0.8.0.ebuild
new file mode 100644
index 000000000000..fad641ffce59
--- /dev/null
+++ b/dev-debug/cgdb/cgdb-0.8.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/cgdb/cgdb.git"
+else
+ SRC_URI="https://github.com/cgdb/cgdb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
+fi
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="A curses front-end for GDB, the GNU debugger"
+HOMEPAGE="https://cgdb.github.io/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+# Tests are broken, need additional research to figure out the cause
+# Bug: https://bugs.gentoo.org/831899
+RESTRICT="test"
+
+DEPEND="
+ sys-libs/ncurses:0=
+ sys-libs/readline:0="
+
+BDEPEND="
+ test? (
+ dev-util/dejagnu
+ app-misc/dtach
+ )"
+
+RDEPEND="
+ ${DEPEND}
+ dev-debug/gdb"
+
+DOCS=( AUTHORS ChangeLog FAQ INSTALL NEWS README.md )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-ar.patch
+)
+
+src_prepare() {
+ default
+ AT_M4DIR="config" eautoreconf
+}
+
+multilib_src_test() {
+ # Tests need an interactive shell, #654986
+
+ # real-time output of the log ;-)
+ touch "${T}/dtach-test.log" || die
+ tail -f "${T}/dtach-test.log" &
+ local tail_pid=${!}
+
+ nonfatal dtach -N "${T}/dtach.sock" \
+ bash -c 'emake check &> "${T}"/dtach-test.log; echo ${?} > "${T}"/dtach-test.out'
+
+ kill "${tail_pid}"
+ [[ -f ${T}/dtach-test.out ]] || die "Unable to run tests"
+ [[ $(<"${T}"/dtach-test.out) == 0 ]] || die "Tests failed"
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf
+}
diff --git a/dev-debug/cgdb/cgdb-9999.ebuild b/dev-debug/cgdb/cgdb-9999.ebuild
new file mode 100644
index 000000000000..cc40b4433455
--- /dev/null
+++ b/dev-debug/cgdb/cgdb-9999.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/cgdb/cgdb.git"
+else
+ SRC_URI="https://github.com/cgdb/cgdb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="A curses front-end for GDB, the GNU debugger"
+HOMEPAGE="https://cgdb.github.io/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+# Tests are broken, need additional research to figure out the cause
+# Bug: https://bugs.gentoo.org/831899
+RESTRICT="test"
+
+DEPEND="
+ sys-libs/ncurses:0=
+ sys-libs/readline:0="
+
+BDEPEND="
+ test? (
+ dev-util/dejagnu
+ app-misc/dtach
+ )"
+
+RDEPEND="
+ ${DEPEND}
+ dev-debug/gdb"
+
+DOCS=( AUTHORS ChangeLog FAQ INSTALL NEWS README.md )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-ar.patch
+)
+
+src_prepare() {
+ default
+ AT_M4DIR="config" eautoreconf
+}
+
+multilib_src_test() {
+ # Tests need an interactive shell, #654986
+
+ # real-time output of the log ;-)
+ touch "${T}/dtach-test.log" || die
+ tail -f "${T}/dtach-test.log" &
+ local tail_pid=${!}
+
+ nonfatal dtach -N "${T}/dtach.sock" \
+ bash -c 'emake check &> "${T}"/dtach-test.log; echo ${?} > "${T}"/dtach-test.out'
+
+ kill "${tail_pid}"
+ [[ -f ${T}/dtach-test.out ]] || die "Unable to run tests"
+ [[ $(<"${T}"/dtach-test.out) == 0 ]] || die "Tests failed"
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf
+}
diff --git a/dev-debug/cgdb/files/cgdb-0.7.1-respect-AR.patch b/dev-debug/cgdb/files/cgdb-0.7.1-respect-AR.patch
new file mode 100644
index 000000000000..e9837855ee3d
--- /dev/null
+++ b/dev-debug/cgdb/files/cgdb-0.7.1-respect-AR.patch
@@ -0,0 +1,32 @@
+From: Jakov Smolic <jakov.smolic@sartura.hr>
+Date: Sun, 6 Sep 2020 11:33:02 +0200
+Subject: [PATCH] configure.init: respect AR
+Bug: https://bugs.gentoo.org/724256
+Patch taken from https://github.com/cgdb/cgdb/pull/142
+
+Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr>
+---
+ configure.init | 7 +++++++
+ 1 file changed, 7 insertions(+)
+
+diff --git a/configure.init b/configure.init
+index 920b2a3..d2f696d 100644
+--- a/configure.init
++++ b/configure.init
+@@ -13,6 +13,13 @@ AC_PROG_INSTALL
+ AC_PROG_RANLIB
+ AM_PROG_LEX
+ AC_PROG_YACC
++m4_ifndef([AC_PROG_AR],[dnl
++ AN_MAKEVAR([AR], [AC_PROG_AR])
++ AN_PROGRAM([ar], [AC_PROG_AR])
++ AC_DEFUN([AC_PROG_AR],
++ [AC_CHECK_TOOL(AR, ar, :)])
++])
++AC_PROG_AR
+
+ dnl determine if we are running in linux, cygwin, solaris, or freebsd
+ AC_CANONICAL_HOST
+--
+2.26.2
+
diff --git a/dev-debug/cgdb/files/cgdb-0.8.0-ar.patch b/dev-debug/cgdb/files/cgdb-0.8.0-ar.patch
new file mode 100644
index 000000000000..128c32ec238c
--- /dev/null
+++ b/dev-debug/cgdb/files/cgdb-0.8.0-ar.patch
@@ -0,0 +1,18 @@
+Bug: https://bugs.gentoo.org/724256
+Patch taken from https://github.com/cgdb/cgdb/pull/142
+--- a/configure.ac
++++ b/configure.ac
+@@ -13,6 +13,13 @@ AC_PROG_INSTALL
+ AC_PROG_RANLIB
+ AM_PROG_LEX
+ AC_PROG_YACC
++m4_ifndef([AC_PROG_AR],[dnl
++ AN_MAKEVAR([AR], [AC_PROG_AR])
++ AN_PROGRAM([ar], [AC_PROG_AR])
++ AC_DEFUN([AC_PROG_AR],
++ [AC_CHECK_TOOL(AR, ar, :)])
++])
++AC_PROG_AR
+
+ dnl determine if we are running in linux, cygwin, solaris, or freebsd
+ AC_CANONICAL_HOST
diff --git a/dev-debug/cgdb/files/cgdb-9999-ar.patch b/dev-debug/cgdb/files/cgdb-9999-ar.patch
new file mode 100644
index 000000000000..ed5f200b3260
--- /dev/null
+++ b/dev-debug/cgdb/files/cgdb-9999-ar.patch
@@ -0,0 +1,16 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -13,6 +13,13 @@ AC_PROG_INSTALL
+ AC_PROG_RANLIB
+ AM_PROG_LEX
+ AC_PROG_YACC
++m4_ifndef([AC_PROG_AR],[dnl
++ AN_MAKEVAR([AR], [AC_PROG_AR])
++ AN_PROGRAM([ar], [AC_PROG_AR])
++ AC_DEFUN([AC_PROG_AR],
++ [AC_CHECK_TOOL(AR, ar, :)])
++])
++AC_PROG_AR
+
+ dnl determine if we are running in linux, cygwin, solaris, or freebsd
+ AC_CANONICAL_HOST
diff --git a/dev-debug/cgdb/files/cgdb-test.patch b/dev-debug/cgdb/files/cgdb-test.patch
new file mode 100644
index 000000000000..9bbb1749828f
--- /dev/null
+++ b/dev-debug/cgdb/files/cgdb-test.patch
@@ -0,0 +1,55 @@
+From a8a567fc46fca4ca10a23016e2fe9055669b9102 Mon Sep 17 00:00:00 2001
+From: Ian Dinwoodie <dinwoodieian@gmail.com>
+Date: Wed, 29 Jan 2020 23:58:13 -0500
+Subject: [PATCH] Ncursesw should link with tinfow.
+
+This patch is a response to issue #219.
+
+Signed-off-by: Ian Dinwoodie <dinwoodieian@gmail.com>
+---
+ config/readline_check_version.m4 | 24 ++++++++++++++++++++----
+ 1 file changed, 20 insertions(+), 4 deletions(-)
+
+diff --git a/config/readline_check_version.m4 b/config/readline_check_version.m4
+index 567bfbd4..01e61c28 100644
+--- a/config/readline_check_version.m4
++++ b/config/readline_check_version.m4
+@@ -7,10 +7,23 @@ AC_MSG_CHECKING(which library has the termcap functions)
+ _bash_needmsg=
+ fi
+ AC_CACHE_VAL(bash_cv_termcap_lib,
+-[AC_CHECK_LIB(]$curses_lib_name[, tgetent, bash_cv_termcap_lib=lib]$curses_lib_name[,
+- [AC_CHECK_LIB(tinfo, tgetent, bash_cv_termcap_lib=libtinfo,
+- [AC_CHECK_FUNC(tgetent, bash_cv_termcap_lib=libc,
+- bash_cv_termcap_lib=gnutermcap)])])])
++[AC_CHECK_FUNC(tgetent, bash_cv_termcap_lib=libc,
++if test "$curses_lib_name" = "ncursesw"; then
++ [AC_CHECK_LIB(ncursesw, tgetent, bash_cv_termcap_lib=libncursesw,
++ [AC_CHECK_LIB(tinfow, tgetent, bash_cv_termcap_lib=libtinfow)]
++ )]
++elif test "$curses_lib_name" = "ncurses"; then
++ [AC_CHECK_LIB(ncurses, tgetent, bash_cv_termcap_lib=libncurses,
++ [AC_CHECK_LIB(tinfo, tgetent, bash_cv_termcap_lib=libtinfo)]
++ )]
++elif test "$curses_lib_name" = "curses"; then
++ [AC_CHECK_LIB(curses, tgetent, bash_cv_termcap_lib=libcurses)]
++else
++ [AC_CHECK_LIB(termcap, tgetent, bash_cv_termcap_lib=libtermcap,
++ bash_cv_termcap_lib=gnutermcap
++ )]
++fi
++)])
+ if test "X$_bash_needmsg" = "Xyes"; then
+ AC_MSG_CHECKING(which library has the termcap functions)
+ fi
+@@ -19,6 +32,9 @@ if test $bash_cv_termcap_lib = gnutermcap && test -z "$prefer_curses"; then
+ LDFLAGS="$LDFLAGS -L./lib/termcap"
+ TERMCAP_LIB="./lib/termcap/libtermcap.a"
+ TERMCAP_DEP="./lib/termcap/libtermcap.a"
++elif test $bash_cv_termcap_lib = libtinfow; then
++TERMCAP_LIB=-ltinfow
++TERMCAP_DEP=
+ elif test $bash_cv_termcap_lib = libtinfo; then
+ TERMCAP_LIB=-ltinfo
+ TERMCAP_DEP=
+
diff --git a/dev-debug/cgdb/metadata.xml b/dev-debug/cgdb/metadata.xml
new file mode 100644
index 000000000000..6dfc01c9d272
--- /dev/null
+++ b/dev-debug/cgdb/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="github">cgdb/cgdb</remote-id>
+ <remote-id type="sourceforge">cgdb</remote-id>
+ </upstream>
+</pkgmetadata>