summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-06 14:12:49 +0100
committerSam James <sam@gentoo.org>2023-05-06 14:13:25 +0100
commitce5c52a0de38d71d1b3824b5589917234d3490d3 (patch)
treeca341c7f32ee2e20c0bc6ef723e4fd2506a167c4 /dev-db/unixODBC
parentnet-misc/electrum-ltc: enable py3.11 (diff)
downloadgentoo-ce5c52a0de38d71d1b3824b5589917234d3490d3.tar.gz
gentoo-ce5c52a0de38d71d1b3824b5589917234d3490d3.tar.bz2
gentoo-ce5c52a0de38d71d1b3824b5589917234d3490d3.zip
dev-db/unixODBC: fix patch & install
I'm sorry, I must have tested the old version instead. Closes: https://bugs.gentoo.org/905819 Fixes: 57836a8512f5f787c78608bbccb8a949020db044 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-db/unixODBC')
-rw-r--r--dev-db/unixODBC/files/unixODBC-2.3.11-config-no-install.patch33
-rw-r--r--dev-db/unixODBC/unixODBC-2.3.11.ebuild14
2 files changed, 44 insertions, 3 deletions
diff --git a/dev-db/unixODBC/files/unixODBC-2.3.11-config-no-install.patch b/dev-db/unixODBC/files/unixODBC-2.3.11-config-no-install.patch
new file mode 100644
index 000000000000..f7b276523f83
--- /dev/null
+++ b/dev-db/unixODBC/files/unixODBC-2.3.11-config-no-install.patch
@@ -0,0 +1,33 @@
+https://github.com/lurcher/unixODBC/commit/685df9e2b4fbbd191ab081a2020956aa78295fe0
+
+From 685df9e2b4fbbd191ab081a2020956aa78295fe0 Mon Sep 17 00:00:00 2001
+From: Hugh McMaster <hugh.mcmaster@outlook.com>
+Date: Fri, 13 May 2022 22:03:37 +1000
+Subject: [PATCH] Makefile.am: Do not install config.h
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,4 +1,4 @@
+-ACLOCAL_AMFLAGS=-I m4
++ACLOCAL_AMFLAGS=-I m4
+
+ pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = \
+@@ -21,7 +21,7 @@ SUBDIRS = \
+ include \
+ doc \
+ man \
+- samples
++ samples
+
+ EXTRA_DIST = \
+ README.OSX \
+@@ -47,7 +47,7 @@ EXTRA_DIST = \
+
+ include_HEADERS = unixodbc.h
+
+-pkginclude_HEADERS = unixodbc_conf.h config.h
++pkginclude_HEADERS = unixodbc_conf.h
+
+ install-data-hook:
+ -$(MKDIR_P) $(DESTDIR)$(sysconfdir)/ODBCDataSources
diff --git a/dev-db/unixODBC/unixODBC-2.3.11.ebuild b/dev-db/unixODBC/unixODBC-2.3.11.ebuild
index 3ab410c7e80e..f6277a5282a5 100644
--- a/dev-db/unixODBC/unixODBC-2.3.11.ebuild
+++ b/dev-db/unixODBC/unixODBC-2.3.11.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit multilib-minimal
+inherit autotools multilib-minimal
DESCRIPTION="Complete ODBC driver manager"
HOMEPAGE="https://www.unixodbc.org/"
@@ -27,12 +27,20 @@ DEPEND="
"
MULTILIB_CHOST_TOOLS=( /usr/bin/odbc_config )
-MULTILIB_WRAPPED_HEADERS=( /usr/include/unixodbc_conf.h )
+MULTILIB_WRAPPED_HEADERS=( /usr/include/unixODBC/unixodbc_conf.h /usr/include/unixodbc.h )
PATCHES=(
- "${FILESDIR}"/${P}-clang16.patch
+ "${FILESDIR}"/${PN}-2.3.9-clang16.patch
+ "${FILESDIR}"/${P}-config-no-install.patch
)
+src_prepare() {
+ default
+
+ # Only needed for config.h install patch
+ eautoreconf
+}
+
multilib_src_configure() {
# Needs flex, bison
export LEX=flex