summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2015-10-04 22:46:51 +0200
committerJulian Ospald <hasufell@gentoo.org>2015-10-04 22:46:51 +0200
commit88f82c7a279e6222a7801862c48a99f249b503d7 (patch)
treeb851894db67558005de2af7bcbc89f64b6cad319 /dev-db/postgresql/postgresql-9999.ebuild
parentmedia-sound/mumble: add libressl support (diff)
downloadgentoo-88f82c7a279e6222a7801862c48a99f249b503d7.tar.gz
gentoo-88f82c7a279e6222a7801862c48a99f249b503d7.tar.bz2
gentoo-88f82c7a279e6222a7801862c48a99f249b503d7.zip
dev-db/postgresql: add libressl support
Diffstat (limited to 'dev-db/postgresql/postgresql-9999.ebuild')
-rw-r--r--dev-db/postgresql/postgresql-9999.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-db/postgresql/postgresql-9999.ebuild b/dev-db/postgresql/postgresql-9999.ebuild
index 5272ee4f2921..6dec347e1338 100644
--- a/dev-db/postgresql/postgresql-9999.ebuild
+++ b/dev-db/postgresql/postgresql-9999.ebuild
@@ -4,7 +4,7 @@
EAPI="5"
-PYTHON_COMPAT=( python{2_{6,7},3_{2,3,4}} )
+PYTHON_COMPAT=( python{2_7,3_4} )
inherit base eutils flag-o-matic git-2 linux-info multilib pam prefix \
python-single-r1 systemd user versionator
@@ -22,7 +22,7 @@ HOMEPAGE="http://www.postgresql.org/"
LINGUAS="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru sk sl sv tr
zh_CN zh_TW"
-IUSE="kerberos kernel_linux ldap nls pam perl -pg_legacytimestamp python
+IUSE="kerberos kernel_linux ldap libressl nls pam perl -pg_legacytimestamp python
+readline selinux +server ssl static-libs tcl threads uuid xml zlib"
for lingua in ${LINGUAS}; do
@@ -49,7 +49,10 @@ pam? ( virtual/pam )
perl? ( >=dev-lang/perl-5.8 )
python? ( ${PYTHON_DEPS} )
readline? ( sys-libs/readline:0= )
-ssl? ( >=dev-libs/openssl-0.9.6-r1:0= )
+ssl? (
+ !libressl? ( >=dev-libs/openssl-0.9.6-r1:0= )
+ libressl? ( dev-libs/libressl:= )
+)
tcl? ( >=dev-lang/tcl-8:0= )
uuid? ( dev-libs/ossp-uuid )
xml? ( dev-libs/libxml2 dev-libs/libxslt )