summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-01-09 21:43:07 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-01-09 22:32:36 +0100
commit2e1a83b86ba545af18e0399453b8c3ad5c263378 (patch)
tree5fe0cbe30b1e130af562c6e1e4eab73fe669cf6d /dev-cpp
parentgames-emulation/pcsx2: update live (diff)
downloadgentoo-2e1a83b86ba545af18e0399453b8c3ad5c263378.tar.gz
gentoo-2e1a83b86ba545af18e0399453b8c3ad5c263378.tar.bz2
gentoo-2e1a83b86ba545af18e0399453b8c3ad5c263378.zip
dev-cpp/catch: Drop 1.12.2 (r0)
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/catch/catch-1.12.2.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-cpp/catch/catch-1.12.2.ebuild b/dev-cpp/catch/catch-1.12.2.ebuild
deleted file mode 100644
index 22741eef0105..000000000000
--- a/dev-cpp/catch/catch-1.12.2.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake-utils
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/catchorg/Catch2.git"
- EGIT_BRANCH="Catch1.x"
-else
- MY_P=${PN^}-${PV}
- SRC_URI="https://github.com/catchorg/Catch2/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
- KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
-
- S="${WORKDIR}/${PN^}2-${PV}"
-fi
-
-DESCRIPTION="Modern C++ header-only framework for unit-tests"
-HOMEPAGE="https://github.com/catchorg/Catch2"
-
-LICENSE="Boost-1.0"
-SLOT="1"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="!<dev-cpp/catch-1.12.2:0"
-
-src_configure() {
- local mycmakeargs=(
- -DNO_SELFTEST=$(usex !test)
- )
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
- dodoc -r docs/.
-}