summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2024-10-14 14:29:34 +0100
committerJoonas Niilola <juippis@gentoo.org>2024-10-17 17:03:03 +0300
commit296c960b8a1d769f7cbb8a9c8daf192e79ef55b4 (patch)
treedbbc5a1f32b37c2a1917ff2512db20d599a180e2 /dev-cpp
parentsci-astronomy/stellarium: drop 24.1 (diff)
downloadgentoo-296c960b8a1d769f7cbb8a9c8daf192e79ef55b4.tar.gz
gentoo-296c960b8a1d769f7cbb8a9c8daf192e79ef55b4.tar.bz2
gentoo-296c960b8a1d769f7cbb8a9c8daf192e79ef55b4.zip
dev-cpp/fast_float: new package, add 6.1.6
Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/fast_float/Manifest1
-rw-r--r--dev-cpp/fast_float/fast_float-6.1.6.ebuild34
-rw-r--r--dev-cpp/fast_float/metadata.xml15
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-cpp/fast_float/Manifest b/dev-cpp/fast_float/Manifest
new file mode 100644
index 000000000000..b4b2a441fd7f
--- /dev/null
+++ b/dev-cpp/fast_float/Manifest
@@ -0,0 +1 @@
+DIST fast_float-6.1.6.tar.gz 101727 BLAKE2B eb9833f7bff6e6086db1525fcc71231c5cc8f47985aa4c71078d896afb5fea20c41bfdb55de6c1e8c9cfa6c9b842331f340115590683e1d9e6a3ba40f4148870 SHA512 d2dbd2537f433329a76539c061238af080125526b7822fbfdf0f70ac0a6800114848b9be0fdf9c51dbb22211af3bdcf9829ed9cc4a47fd28ecdeecf7c5d4b663
diff --git a/dev-cpp/fast_float/fast_float-6.1.6.ebuild b/dev-cpp/fast_float/fast_float-6.1.6.ebuild
new file mode 100644
index 000000000000..afa18fe2c69b
--- /dev/null
+++ b/dev-cpp/fast_float/fast_float-6.1.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Fast and exact implementation of the C++ from_chars functions for number types"
+HOMEPAGE="https://github.com/fastfloat/fast_float"
+SRC_URI="https://github.com/fastfloat/fast_float/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 Boost-1.0 MIT )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+BDEPEND="test? ( dev-cpp/doctest )"
+
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=( -DFASTFLOAT_TEST=$(usex test) )
+ # Avoid passing these without USE=test to avoid cmake warning
+ # "Manually-specified variables were not used by the project"
+ use test && mycmakeargs+=(
+ -DSYSTEM_DOCTEST=ON
+ # Unconditionally calls FetchContent
+ -DFASTFLOAT_SUPPLEMENTAL_TESTS=OFF
+ )
+
+ sed -i 's/-Werror//' tests/CMakeLists.txt || die
+
+ cmake_src_configure
+}
diff --git a/dev-cpp/fast_float/metadata.xml b/dev-cpp/fast_float/metadata.xml
new file mode 100644
index 000000000000..ec84f74b1736
--- /dev/null
+++ b/dev-cpp/fast_float/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>stffn.mobil@freenet.de</email>
+ <name>Steffen Winter</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">fastfloat/fast_float</remote-id>
+ </upstream>
+</pkgmetadata>