summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-28 23:49:38 +0000
committerSam James <sam@gentoo.org>2021-12-29 00:13:51 +0000
commit7571d22a49cdce0626968667e68638ff2111471e (patch)
treea11161e68869accbd59250577df6a2e83eec52b7 /dev-cpp/catch/catch-1.12.2-r1.ebuild
parentapp-emulation/protontricks: call xdg_desktop_database_update (diff)
downloadgentoo-7571d22a49cdce0626968667e68638ff2111471e.tar.gz
gentoo-7571d22a49cdce0626968667e68638ff2111471e.tar.bz2
gentoo-7571d22a49cdce0626968667e68638ff2111471e.zip
dev-cpp/catch: patch for glibc-2.34
Kind of cheesy patch but it is what it is, Catch1 is dead anyway. Closes: https://bugs.gentoo.org/803962 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp/catch/catch-1.12.2-r1.ebuild')
-rw-r--r--dev-cpp/catch/catch-1.12.2-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-cpp/catch/catch-1.12.2-r1.ebuild b/dev-cpp/catch/catch-1.12.2-r1.ebuild
new file mode 100644
index 000000000000..9120c50ed593
--- /dev/null
+++ b/dev-cpp/catch/catch-1.12.2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/catchorg/Catch2.git"
+ EGIT_BRANCH="Catch1.x"
+else
+ MY_P=${PN^}-${PV}
+ SRC_URI="https://github.com/catchorg/Catch2/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+ S="${WORKDIR}/${PN^}2-${PV}"
+fi
+
+DESCRIPTION="Modern C++ header-only framework for unit-tests"
+HOMEPAGE="https://github.com/catchorg/Catch2"
+
+LICENSE="Boost-1.0"
+SLOT="1"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="!<dev-cpp/catch-1.12.2:0"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.12.2-glibc-2.34-sigstksz.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DNO_SELFTEST=$(usex !test)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ dodoc -r docs/.
+}