summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-07-12 09:20:48 +0100
committerSam James <sam@gentoo.org>2024-07-12 11:28:30 +0100
commitd64b2daab87b811b336e375caf5a8959201e1435 (patch)
treeab26978c3d907c4f02ad8123e74a18daa54002e8 /dev-build
parentdev-python/ipywidgets: Add a pytest-8 fix (diff)
downloadgentoo-d64b2daab87b811b336e375caf5a8959201e1435.tar.gz
gentoo-d64b2daab87b811b336e375caf5a8959201e1435.tar.bz2
gentoo-d64b2daab87b811b336e375caf5a8959201e1435.zip
dev-build/automake-vanilla: add 1.17
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-build')
-rw-r--r--dev-build/automake-vanilla/Manifest1
-rw-r--r--dev-build/automake-vanilla/automake-vanilla-1.17.ebuild130
2 files changed, 131 insertions, 0 deletions
diff --git a/dev-build/automake-vanilla/Manifest b/dev-build/automake-vanilla/Manifest
index bb286c7460e1..eb9149f14456 100644
--- a/dev-build/automake-vanilla/Manifest
+++ b/dev-build/automake-vanilla/Manifest
@@ -2,3 +2,4 @@ DIST automake-1.11.6.tar.xz 1092908 BLAKE2B 17254d81d6920c32aa877b6c892025de8e40
DIST automake-1.15.1.tar.xz 1509496 BLAKE2B e6ade31089f969140472004cd9854318470228c64e4f8e829d48c5379f62d2c5f8ef9509131c577653e81868d94544ecf6520f86b5d582ebb6ed65c832039f30 SHA512 02f661b2676f1d44334ce1c7188f9913a6874bf46ba487708ad8090ad57905f14aead80fefed815e21effacfbb925e23b944ea7dd32563dca39c1a4174eda688
DIST automake-1.16.5-tests-c99.patch.xz 7176 BLAKE2B 1fa1d3a499bacc5da9ee9d8ea6cb63d9ab91646a708a53d9bb08eef65fe02a6ab34ff95737042348ea7572bd70c6c7467e260d9441239a00c3571d25d73085f0 SHA512 0065b809219257cbce3c6f6f88459b91a5a29272e0027698e06246181357ffe8d5d40057086438f891d821836441a5a96f2568d52dcd3b5acb80e4d4968cbaf9
DIST automake-1.16.5.tar.xz 1601740 BLAKE2B 87408abc57e1d4317a2b518fb3606d0f6d156522e7333016dd84747cd8922f27ef7fcc93220b11f794ce52bf8fd9a788d0166a4d1964d7c283905f269977ac7c SHA512 3084ae543aa3fb5a05104ffb2e66cfa9a53080f2343c44809707fd648516869511500dba50dae67ff10f92a1bf3b5a92b2a0fa01cda30adb69b9da03994d9d88
+DIST automake-1.17.tar.xz 1652632 BLAKE2B 53c24c138faf3d2be4e30ababcccd4d157c03e815fc4b7f3e3063b6648cf254dfa63afe6e3285b21309dbf260335c3e67991db3825e7532b158b25ccaead83f5 SHA512 46aba1c9d64a6368b326020803a2999831c1deaf31eaa1c1dfdcfa5138a7f755643294e82a08b6daab3983b31eee725bdb7b9edc4e9a558374c7d1f1b8e854a7
diff --git a/dev-build/automake-vanilla/automake-vanilla-1.17.ebuild b/dev-build/automake-vanilla/automake-vanilla-1.17.ebuild
new file mode 100644
index 000000000000..21168cdee797
--- /dev/null
+++ b/dev-build/automake-vanilla/automake-vanilla-1.17.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Please do not apply any patches which affect the generated output from
+# `automake`, as this package is used to submit patches upstream.
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit python-any-r1
+
+MY_PN=${PN/-vanilla}
+MY_P=${MY_PN}-${PV}
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://git.savannah.gnu.org/r/${MY_PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://gnu/${MY_PN}/${MY_P}.tar.xz"
+
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="Used to generate Makefile.in from Makefile.am"
+HOMEPAGE="https://www.gnu.org/software/automake/"
+
+LICENSE="GPL-2"
+# Use Gentoo versioning for slotting.
+SLOT="${PV:0:4}"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-lang/perl-5.6
+ >=dev-build/automake-wrapper-11
+ >=dev-build/autoconf-2.69:*
+ sys-devel/gnuconfig
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-alternatives/gzip
+ sys-apps/help2man
+ test? (
+ ${PYTHON_DEPS}
+ dev-util/dejagnu
+ sys-devel/bison
+ sys-devel/flex
+ )
+"
+
+pkg_setup() {
+ # Avoid python-any-r1_pkg_setup
+ :
+}
+
+src_prepare() {
+ default
+
+ export WANT_AUTOCONF=2.5
+ # Don't try wrapping the autotools - this thing runs as it tends
+ # to be a bit esoteric, and the script does `set -e` itself.
+ ./bootstrap || die
+ sed -i -e "/APIVERSION=/s:=.*:=${SLOT}:" configure || die
+
+ # bug #628912
+ if ! has_version -b sys-apps/texinfo ; then
+ touch doc/{stamp-vti,version.texi,automake.info} || die
+ fi
+}
+
+src_configure() {
+ use test && python_setup
+ # Also used in install.
+ MY_INFODIR="${EPREFIX}/usr/share/${P}/info"
+ econf \
+ --datadir="${EPREFIX}"/usr/share/automake-vanilla-${PV} \
+ --program-suffix="-vanilla" \
+ --infodir="${MY_INFODIR}"
+}
+
+src_test() {
+ # Fails with byacc/flex
+ emake YACC="bison -y" LEX="flex" check
+}
+
+src_install() {
+ default
+
+ #rm "${ED}"/usr/share/aclocal/README || die
+ #rmdir "${ED}"/usr/share/aclocal || die
+ rm \
+ "${ED}"/usr/bin/{aclocal,automake}-vanilla \
+ "${ED}"/usr/share/man/man1/{aclocal,automake}-vanilla.1 || die
+
+ # remove all config.guess and config.sub files replacing them
+ # w/a symlink to a specific gnuconfig version
+ local x
+ for x in guess sub ; do
+ dosym ../gnuconfig/config.${x} \
+ /usr/share/${PN}-${SLOT}/config.${x}
+ done
+
+ # Avoid QA message about pre-compressed file in docs
+ local tarfile="${ED}/usr/share/doc/automake-vanilla-${PVR}/amhello-1.0.tar.gz"
+ if [[ -f "${tarfile}" ]] ; then
+ gunzip "${tarfile}" || die
+ fi
+
+ pushd "${D}/${MY_INFODIR}" >/dev/null || die
+ for f in *.info*; do
+ # Install convenience aliases for versioned Automake pages.
+ ln -s "$f" "${f/./-vanilla-${PV}.}" || die
+ done
+ popd >/dev/null || die
+
+ if [[ ${PV} == 9999 ]]; then
+ local major="89"
+ local minor="999"
+ else
+ local major="$(ver_cut 1)"
+ local minor="$(ver_cut 2)"
+ fi
+ local idx="$((99999-(major*1000+minor)))"
+ newenvd - "07automake${idx}" <<-EOF
+ INFOPATH="${MY_INFODIR}"
+ EOF
+
+ docompress "${MY_INFODIR}"
+}