summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-09 17:32:13 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-09 20:15:48 +0100
commit6a637f808e44c52c460b849e838e7db42de21aea (patch)
tree2a52f84df074d8f48cb7509a36f5b9e3f9012650 /dev-build
parentx11-wm/mutter: drop 44.4 (diff)
downloadgentoo-6a637f808e44c52c460b849e838e7db42de21aea.tar.gz
gentoo-6a637f808e44c52c460b849e838e7db42de21aea.tar.bz2
gentoo-6a637f808e44c52c460b849e838e7db42de21aea.zip
dev-build/automake: Backport a py3.12 test fix
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-build')
-rw-r--r--dev-build/automake/automake-1.16.5-r2.ebuild3
-rw-r--r--dev-build/automake/files/automake-1.16.5-py312.patch34
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-build/automake/automake-1.16.5-r2.ebuild b/dev-build/automake/automake-1.16.5-r2.ebuild
index ce41b4760596..d4553e58b66f 100644
--- a/dev-build/automake/automake-1.16.5-r2.ebuild
+++ b/dev-build/automake/automake-1.16.5-r2.ebuild
@@ -8,7 +8,7 @@ EAPI=7
# on new automake (major) releases, as well as the dependency in RDEPEND below too.
# * Update _WANT_AUTOMAKE and _automake_atom case statement in autotools.eclass.
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit python-any-r1
@@ -69,6 +69,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.16.5-fix-py-compile-basedir.sh-test.patch
"${FILESDIR}"/${PN}-1.16.5-apostrophe-in-tests.patch
"${FILESDIR}"/${PN}-1.16.5-parallel-build.patch
+ "${FILESDIR}"/${PN}-1.16.5-py312.patch
"${WORKDIR}"/${PN}-1.16.5-tests-c99.patch
)
diff --git a/dev-build/automake/files/automake-1.16.5-py312.patch b/dev-build/automake/files/automake-1.16.5-py312.patch
new file mode 100644
index 000000000000..124403f1db2b
--- /dev/null
+++ b/dev-build/automake/files/automake-1.16.5-py312.patch
@@ -0,0 +1,34 @@
+https://git.savannah.gnu.org/cgit/automake.git/commit/?id=f1112a88d2361eb2ba5cedf49995ac75879059d9
+
+From f1112a88d2361eb2ba5cedf49995ac75879059d9 Mon Sep 17 00:00:00 2001
+From: Bogdan <bogdro_rep@gmx.us>
+Date: Sun, 28 Jan 2024 18:12:50 -0800
+Subject: [PATCH] test: another check for PEP-3147 induced by Python 3.12.1.
+
+Fix for more of https://bugs.gnu.org/68119.
+
+* t/ax/am-test-lib.sh (python_has_pep3147) <am_pep3147_tag>:
+check sys.implementation.cache_tag as well as the (old)
+imp.get_tag. For Python 3.12.1.
+---
+ t/ax/am-test-lib.sh | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/t/ax/am-test-lib.sh b/t/ax/am-test-lib.sh
+index fbbb79005..d61fd6662 100644
+--- a/t/ax/am-test-lib.sh
++++ b/t/ax/am-test-lib.sh
+@@ -635,6 +635,10 @@ python_has_pep3147 ()
+ am_pep3147_tag=$($PYTHON -c 'import imp; print(imp.get_tag())') \
+ || am_pep3147_tag=none
+ fi
++ if test "$am_pep3147_tag" = "none"; then
++ am_pep3147_tag=$($PYTHON -c 'import sys; print(sys.implementation.cache_tag)') \
++ || am_pep3147_tag=none
++ fi
+ test $am_pep3147_tag != none
+ }
+ am_pep3147_tag=
+--
+2.44.0
+