summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2023-11-11 02:14:01 +0200
committerSam James <sam@gentoo.org>2023-11-22 12:02:13 +0000
commitf2add7ff30dec6bb62efb106210f0bd51e5d4403 (patch)
treeae1fc2a3e8ef300886a0c916b9f879816e0f3543 /app-text
parentdev-python/sphinx-tabs: Remove old (diff)
downloadgentoo-f2add7ff30dec6bb62efb106210f0bd51e5d4403.tar.gz
gentoo-f2add7ff30dec6bb62efb106210f0bd51e5d4403.tar.bz2
gentoo-f2add7ff30dec6bb62efb106210f0bd51e5d4403.zip
app-text/xmldiff: add 2.6.3
Closes: https://bugs.gentoo.org/909903 Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/xmldiff/Manifest1
-rw-r--r--app-text/xmldiff/xmldiff-2.6.3.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/app-text/xmldiff/Manifest b/app-text/xmldiff/Manifest
index 233ce86eac09..8913a6b305b1 100644
--- a/app-text/xmldiff/Manifest
+++ b/app-text/xmldiff/Manifest
@@ -1 +1,2 @@
DIST xmldiff-2.4.tar.gz 93437 BLAKE2B 9f0001da8e39b7a3e7d0af052ce60a43899b2cd644b3fa6c6cb7cfa08ebf71439bda3e3dc6cf497120f20cb0f9346b0a074b8e442b42531fd3bdbaaebdf73bf6 SHA512 d8a0c9cb850259b3288d8fb5fde50c69f24036bc46ea48f24f3d63c592ccdd2aab4daf416f0f75b38fd70cc58e00c12db626e61a983d1a002972a6720d62c6ae
+DIST xmldiff-2.6.3.tar.gz 86132 BLAKE2B 9e5777f498677bf12a603d6636833d4942fb1af2c461e9a60e2dccf89c3776f72018407928991c8a9f53abe8c704ca9a736a4f0f81ce3ca23e1657a896d43804 SHA512 ba25b8cc9866c66bc829a82d1f20108c17a09e2f46735763317f7fd6f60c3920ba6d3114454ead1461de4a59c177065291bb71bebb7ee9c4a03f3584452a9e33
diff --git a/app-text/xmldiff/xmldiff-2.6.3.ebuild b/app-text/xmldiff/xmldiff-2.6.3.ebuild
new file mode 100644
index 000000000000..98cfbbde2b9a
--- /dev/null
+++ b/app-text/xmldiff/xmldiff-2.6.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A tool that figures out the differences between two similar XML files"
+HOMEPAGE="
+ https://github.com/Shoobx/xmldiff
+ https://pypi.org/project/xmldiff/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-linux"
+
+RDEPEND="
+ >=dev-python/lxml-3.1.0[${PYTHON_USEDEP}]
+"
+
+DOCS=( CHANGES.rst README.rst )
+
+distutils_enable_tests unittest