summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/robodoc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/robodoc')
-rw-r--r--app-text/robodoc/Manifest1
-rw-r--r--app-text/robodoc/metadata.xml5
-rw-r--r--app-text/robodoc/robodoc-4.99.36.ebuild37
3 files changed, 43 insertions, 0 deletions
diff --git a/app-text/robodoc/Manifest b/app-text/robodoc/Manifest
new file mode 100644
index 000000000000..a6136457fb45
--- /dev/null
+++ b/app-text/robodoc/Manifest
@@ -0,0 +1 @@
+DIST robodoc-4.99.36.tar.gz 280680 SHA256 d38279746204d8862d8436042b089d8c9dffefec6e7f33224f955d82b965a029 SHA512 6643cb1419c58195f26899e629a4a7470014b425e05b7615e523f972b67eb0e39421c373b8c80b53a4dd0d121d61481a7a0e66f7fca7fe82422d56b8ff048b9b WHIRLPOOL cbb3afdf6cd75c8dae47822a2cd9def070557daafb3ea31a138b115ebe3c531990ba50ddd0fd402b7c013dbadf376ac8e7c4c5ea685c41dc781e571bec4ecfa2
diff --git a/app-text/robodoc/metadata.xml b/app-text/robodoc/metadata.xml
new file mode 100644
index 000000000000..4538a68724a6
--- /dev/null
+++ b/app-text/robodoc/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/app-text/robodoc/robodoc-4.99.36.ebuild b/app-text/robodoc/robodoc-4.99.36.ebuild
new file mode 100644
index 000000000000..61697c29edee
--- /dev/null
+++ b/app-text/robodoc/robodoc-4.99.36.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Automating Software Documentation"
+HOMEPAGE="http://www.xs4all.nl/~rfsber/Robo/robodoc.html"
+SRC_URI="http://www.xs4all.nl/~rfsber/Robo/DistSource/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND=">=dev-util/ctags-5.3.1"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ --disable-dependency-tracking
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ insinto /usr/share/${PN}
+ doins Contributions/* || die "doins failed"
+
+ rm -f "${D}"/usr/share/doc/${PF}/{COPYING,INSTALL}
+
+ if use examples; then
+ insinto /usr/share/${PN}
+ doins -r Examples/PerlExample || die "doins failed"
+ fi
+}