summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2023-11-07 13:40:52 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2023-11-07 15:51:25 +0100
commit92cbcfc445e801775cd0c50f2115bd463169beb5 (patch)
tree494fc3565a28d1d71cc10356423dae734aff6228 /app-text/openpaperwork-gtk
parentapp-text/openpaperwork-core: add 2.2.1 (diff)
downloadgentoo-92cbcfc445e801775cd0c50f2115bd463169beb5.tar.gz
gentoo-92cbcfc445e801775cd0c50f2115bd463169beb5.tar.bz2
gentoo-92cbcfc445e801775cd0c50f2115bd463169beb5.zip
app-text/openpaperwork-gtk: add 2.2.1
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'app-text/openpaperwork-gtk')
-rw-r--r--app-text/openpaperwork-gtk/Manifest1
-rw-r--r--app-text/openpaperwork-gtk/openpaperwork-gtk-2.2.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-text/openpaperwork-gtk/Manifest b/app-text/openpaperwork-gtk/Manifest
index 0cf509707431..5105be2f8cc7 100644
--- a/app-text/openpaperwork-gtk/Manifest
+++ b/app-text/openpaperwork-gtk/Manifest
@@ -1 +1,2 @@
DIST openpaperwork-gtk-2.1.2.tar.gz 59104 BLAKE2B 94782b0fbd29e749b68f277e5c48a8f194d4feafe2f1579615b51bed44855a9113631302e3ed0f8248683ba524e72147da7cdce76e54b266ae9d8dbaa5cba2a5 SHA512 9f11482e68ee01356644fc2a679044a835308f6591b1b3ef6fc079c26e87a5c8c7fa8ba23545e7bf7fc9d37d85151a70cd7bdf4c45c271f67f8a8dcf95a5c440
+DIST paperwork-2.2.1.tar.bz2 2529505 BLAKE2B e5545d3fbb5e41d0ddd21a0358fae496d127b30a3f72e1438eef679c520a3152e4db006d9dc42023431907281452931e90aea187c4928309bde7add2d54b5844 SHA512 f96ddf3efe3b5021e612600fa2e3a9c83db7ec78b9637e434facefcc422700be1b67b74231b4738a7762905ac5267f412839ff9d43cb9dcf7f95a5f3d6f7091f
diff --git a/app-text/openpaperwork-gtk/openpaperwork-gtk-2.2.1.ebuild b/app-text/openpaperwork-gtk/openpaperwork-gtk-2.2.1.ebuild
new file mode 100644
index 000000000000..c63bc8735923
--- /dev/null
+++ b/app-text/openpaperwork-gtk/openpaperwork-gtk-2.2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Paperwork plugins"
+HOMEPAGE="https://gitlab.gnome.org/World/OpenPaperwork"
+SRC_URI="https://gitlab.gnome.org/World/OpenPaperwork/paperwork/-/archive/${PV}/paperwork-${PV}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-text/openpaperwork-core[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gui-libs/libhandy
+ x11-libs/gtk+:3[introspection]"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-python/setuptools-scm[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/paperwork-${PV}/${PN}
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}