summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-11-23 20:03:24 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-12-17 16:55:34 +0100
commit8247a2c52971aac4fbdafd4ce44b4116dab328de (patch)
tree321f1623d954a4c93331f18d007eabaca2e27003 /app-text/libmwaw/libmwaw-0.3.8.ebuild
parentdev-util/mdds: Drop eutils.eclass, more EAPI 6 polish (diff)
downloadgentoo-8247a2c52971aac4fbdafd4ce44b4116dab328de.tar.gz
gentoo-8247a2c52971aac4fbdafd4ce44b4116dab328de.tar.bz2
gentoo-8247a2c52971aac4fbdafd4ce44b4116dab328de.zip
app-text/libmwaw: 0.3.9 version bump, USE=tools, --with-sharedptr=c++11
Drop eutils.eclass Package-Manager: portage-2.3.0
Diffstat (limited to 'app-text/libmwaw/libmwaw-0.3.8.ebuild')
-rw-r--r--app-text/libmwaw/libmwaw-0.3.8.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/app-text/libmwaw/libmwaw-0.3.8.ebuild b/app-text/libmwaw/libmwaw-0.3.8.ebuild
index 234cf6f9f63e..5a1b195dbd9e 100644
--- a/app-text/libmwaw/libmwaw-0.3.8.ebuild
+++ b/app-text/libmwaw/libmwaw-0.3.8.ebuild
@@ -5,11 +5,10 @@
EAPI=6
EGIT_REPO_URI="git://git.code.sf.net/p/libmwaw/libmwaw"
-inherit eutils
[[ ${PV} == 9999 ]] && inherit autotools git-r3
DESCRIPTION="Library parsing many pre-OSX MAC text formats"
-HOMEPAGE="http://sourceforge.net/p/libmwaw/wiki/Home/"
+HOMEPAGE="https://sourceforge.net/p/libmwaw/wiki/Home/"
[[ ${PV} == 9999 ]] || SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
LICENSE="LGPL-2.1"
@@ -26,7 +25,7 @@ RDEPEND="
sys-libs/zlib
"
DEPEND="${RDEPEND}
- >=dev-libs/boost-1.46:=
+ dev-libs/boost
sys-devel/libtool
virtual/pkgconfig
doc? ( app-doc/doxygen )
@@ -40,15 +39,14 @@ src_prepare() {
src_configure() {
# zip is hard enabled as the zlib is dep on the rdeps anyway
econf \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- --with-sharedptr=boost \
--enable-zip \
--disable-werror \
- $(use_enable static-libs static) \
- $(use_with doc docs)
+ --with-sharedptr=boost \
+ $(use_with doc docs) \
+ $(use_enable static-libs static)
}
src_install() {
default
- prune_libtool_files --all
+ find "${D}" -name '*.la' -delete || die
}