summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <ya@sysdump.net>2017-06-06 17:12:44 -0700
committerLars Wendler <polynomial-c@gentoo.org>2017-06-07 02:55:02 +0200
commite19a14863b97b868940c6aea6c233b9a9b01ae07 (patch)
tree658fe645893da1fa08fb2957585cd213dbccaae8 /app-shells
parentsys-devel/binutils: Keyword 2.28, bug #617822 (diff)
downloadgentoo-e19a14863b97b868940c6aea6c233b9a9b01ae07.tar.gz
gentoo-e19a14863b97b868940c6aea6c233b9a9b01ae07.tar.bz2
gentoo-e19a14863b97b868940c6aea6c233b9a9b01ae07.zip
app-shells/fish: version bump to 2.6.0
This also removes linguas patch as it's included upstream. Package-Manager: Portage-2.3.5, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/4877
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/fish/Manifest1
-rw-r--r--app-shells/fish/fish-2.6.0.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/app-shells/fish/Manifest b/app-shells/fish/Manifest
index 858f28c23684..7db0b4d98b16 100644
--- a/app-shells/fish/Manifest
+++ b/app-shells/fish/Manifest
@@ -1,2 +1,3 @@
DIST fish-2.4.0.tar.gz 3455874 SHA256 06bbb2323360439c4044da762d114ec1aa1aba265cec71c0543e6a0095c9efc5 SHA512 b27a2291c284fda7a12b3cd5dcba8dfcbf2738f50de40d9aac1500afa3bd98be04b4f67d7e6d3bb2f808c11a8c2dd6b1b5cc2dfe3e8e0e7d1bc88f8d8994d57b WHIRLPOOL abb9c31237a33553b25920fe3284f4ca90941aed2b8f1ec4b69fdb4231f7b2585f0292bc647ffe3acf88f6b01ac61931f615fa9a56ede35a8182e3a69aa11861
DIST fish-2.5.0.tar.gz 3496831 SHA256 f8c0edadca2de379ccf305aeace660a9255fa2180c72e85e97705a24c256b2a5 SHA512 6d94bb70a5f1cefaada4d10ac845992f87c9bfc8c253f38bdfcc3a573a35503d825c9487d2ce8ef3819713594ab7b54ebf6c89fe3362c7010c63dbefc99b424d WHIRLPOOL a16d5f75e95573f2b766527fb124d99083a7ab84522a4826cd5b3aaf3a73ae6728f30defbd0598698b496f279f686eddcb4e81779767e89888037abe0b908849
+DIST fish-2.6.0.tar.gz 3575346 SHA256 7ee5bbd671c73e5323778982109241685d58a836e52013e18ee5d9f2e638fdfb SHA512 d4ded5ce24600e85673a7bb016e9dc36bce999b27f40e6b1ce0b9ca49a421be2d444d9d2b6f178f6eee963e59daa4a65df4c3de2a8086a610486f758fcfb0ed1 WHIRLPOOL 3316c1bd8778a1eba5b7b65edf28495ec89ec01ba3d0bc26cbc64ce69bfcd73a538c9a5463c9385f55689e3e680241d37e36bfec309f87c6ee98934f74fd7aa4
diff --git a/app-shells/fish/fish-2.6.0.ebuild b/app-shells/fish/fish-2.6.0.ebuild
new file mode 100644
index 000000000000..28ec96ac5a5e
--- /dev/null
+++ b/app-shells/fish/fish-2.6.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="fish is the Friendly Interactive SHell"
+HOMEPAGE="http://fishshell.com/"
+SRC_URI="https://github.com/${PN}-shell/${PN}-shell/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="nls"
+
+RDEPEND="
+ >=dev-libs/libpcre2-10.21[pcre32]
+ sys-libs/ncurses:0=
+"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/bc
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ # Set things up for fish to be a default shell.
+ # It has to be in /bin in case /usr is unavailable.
+ # Also, all of its utilities have to be in /bin.
+ econf \
+ docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --bindir="${EPREFIX}"/bin \
+ --without-included-pcre2 \
+ $(use_with nls gettext)
+}
+
+src_test() {
+ if has_version ~${CATEGORY}/${P} ; then
+ emake test
+ else
+ ewarn "The test suite only works when the package is already installed"
+ fi
+}
+
+pkg_postinst() {
+ elog "fish is now installed on your system."
+ elog "To run fish, type 'fish' in your terminal."
+ elog
+ elog "It is advised not to set fish as a default login shell."
+ elog "see bug #545830 for more details."
+ elog "Executing fish using ~/.bashrc is an alternative"
+ elog "see https://wiki.gentoo.org/wiki/Fish#Caveats for details"
+ elog
+ elog "To set your colors, run 'fish_config'"
+ elog "To scan your man pages for completions, run 'fish_update_completions'"
+ elog "To autocomplete command suggestions press Ctrl + F or right arrow key."
+ elog
+ elog "Please add a \"BROWSER\" variable to ${PN}'s environment pointing to the"
+ elog "browser of your choice to get acces to ${PN}'s help system:"
+ elog " BROWSER=\"/usr/bin/firefox\""
+ elog
+ elog "In order to get lzma and xz support for man-page completion please"
+ elog "emerge one of the following packages:"
+ elog " dev-python/backports-lzma"
+ elog " >=dev-lang/python-3.3"
+ elog
+ elog "If you have issues with cut'n'paste in X-terminals, install the"
+ elog "x11-misc/xsel package."
+ elog
+ elog "Have fun!"
+}