summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-05-21 22:50:00 -0400
committerSam James <sam@gentoo.org>2024-05-22 05:34:30 +0100
commit9d95ea1c4f26dcb47bc851039f51b75c726e4bdd (patch)
treefaaee4817be16ca2b55a537f0860d7ab1c3f899b /app-shells
parentdev-perl/CDB_File: EAPI 8, rely on eclass impls (diff)
downloadgentoo-9d95ea1c4f26dcb47bc851039f51b75c726e4bdd.tar.gz
gentoo-9d95ea1c4f26dcb47bc851039f51b75c726e4bdd.tar.bz2
gentoo-9d95ea1c4f26dcb47bc851039f51b75c726e4bdd.zip
app-shells/bash: add whitelist for false positive configure implicit decls
makedev isn't supposed to exist where it is being checked here, but the check itself vanishes in modern autoconf, and is thus unneeded for bash 5.2+. Whitelist it just for the current version, which predates that. Closes: https://bugs.gentoo.org/916480 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/bash-5.1_p16-r10.ebuild6
-rw-r--r--app-shells/bash/bash-5.1_p16-r6.ebuild6
2 files changed, 12 insertions, 0 deletions
diff --git a/app-shells/bash/bash-5.1_p16-r10.ebuild b/app-shells/bash/bash-5.1_p16-r10.ebuild
index 2f4a6284d0a0..9141fddae28e 100644
--- a/app-shells/bash/bash-5.1_p16-r10.ebuild
+++ b/app-shells/bash/bash-5.1_p16-r10.ebuild
@@ -88,6 +88,12 @@ BDEPEND="
# EAPI 8 tries to append it but it doesn't exist here.
QA_CONFIGURE_OPTIONS="--disable-static"
+QA_CONFIG_IMPL_DECL_SKIP+=(
+ # this is fixed in autoconf 2.71, used in bash 5.2. The check fails
+ # regardless of GCC version. bug #916480
+ makedev
+)
+
PATCHES=(
#"${WORKDIR}"/${PN}-${GENTOO_PATCH_VER}/
diff --git a/app-shells/bash/bash-5.1_p16-r6.ebuild b/app-shells/bash/bash-5.1_p16-r6.ebuild
index 7af661f690f8..488dbff0dc94 100644
--- a/app-shells/bash/bash-5.1_p16-r6.ebuild
+++ b/app-shells/bash/bash-5.1_p16-r6.ebuild
@@ -96,6 +96,12 @@ BDEPEND="sys-devel/bison
S="${WORKDIR}/${MY_P}"
+QA_CONFIG_IMPL_DECL_SKIP+=(
+ # this is fixed in autoconf 2.71, used in bash 5.2. The check fails
+ # regardless of GCC version. bug #916480
+ makedev
+)
+
PATCHES=(
# Patches from Chet sent to bashbug ml
"${WORKDIR}"/${PN}-${GENTOO_PATCH_VER}-patches/${PN}-5.0-syslog-history-extern.patch