summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-05-10 19:18:33 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-05-10 19:22:17 +0200
commit6964e363456ade12c124d784e8335a850a9705be (patch)
tree03b137389871a1c09cfd9e02df0c3d356bfef6cc /app-shells
parentnet-print/epson-inkjet-printer-escpr: stabilize 1.8.5 for amd64, ppc64 (diff)
downloadgentoo-6964e363456ade12c124d784e8335a850a9705be.tar.gz
gentoo-6964e363456ade12c124d784e8335a850a9705be.tar.bz2
gentoo-6964e363456ade12c124d784e8335a850a9705be.zip
app-shells/pwsh: check for locales in pkg_pretend
Bug: https://bugs.gentoo.org/931648 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/pwsh/pwsh-7.4.1.ebuild32
1 files changed, 21 insertions, 11 deletions
diff --git a/app-shells/pwsh/pwsh-7.4.1.ebuild b/app-shells/pwsh/pwsh-7.4.1.ebuild
index d322f45e998c..7431aec62918 100644
--- a/app-shells/pwsh/pwsh-7.4.1.ebuild
+++ b/app-shells/pwsh/pwsh-7.4.1.ebuild
@@ -296,17 +296,7 @@ PATCHES=(
DOCS=( CHANGELOG CHANGELOG.md CODE_OF_CONDUCT.md README.md docs )
-gui_cache_update() {
- if use gui ; then
- xdg_icon_cache_update
- xdg_desktop_database_update
- fi
-}
-
-pkg_setup() {
- check-reqs_pkg_setup
- dotnet-pkg_pkg_setup
-
+check_requirements_locale() {
if [[ "${MERGE_TYPE}" != binary ]] ; then
if use elibc_glibc ; then
local locales
@@ -331,6 +321,26 @@ pkg_setup() {
fi
}
+gui_cache_update() {
+ if use gui ; then
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ fi
+}
+
+pkg_pretend() {
+ check-reqs_pkg_pretend
+
+ check_requirements_locale
+}
+
+pkg_setup() {
+ check-reqs_pkg_setup
+ dotnet-pkg_pkg_setup
+
+ check_requirements_locale
+}
+
src_prepare() {
dotnet-pkg_src_prepare