summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2021-12-31 01:11:18 +0100
committerMaciej Barć <xgqt@gentoo.org>2021-12-31 01:31:22 +0100
commit93fbed6e982f91eb32076fbf42c017cfcdd6c7ac (patch)
tree98bc58c0405e7d20b4dabdadc10b0c3cf8276d2e /app-shells/scsh/files
parentapp-admin/supervisor: drop 4.2.0, 4.2.1 (diff)
downloadgentoo-93fbed6e982f91eb32076fbf42c017cfcdd6c7ac.tar.gz
gentoo-93fbed6e982f91eb32076fbf42c017cfcdd6c7ac.tar.bz2
gentoo-93fbed6e982f91eb32076fbf42c017cfcdd6c7ac.zip
app-shells/scsh: build only on 32bit arches; tests; format
libcrypt/GCC not being 32bit/multilib bugs: - https://bugs.gentoo.org/589122 - https://bugs.gentoo.org/710570 - https://bugs.gentoo.org/830282 Thanks for patches: - SCSH_LIB_DIRS environment variable: adam@michalik.es https://bugs.gentoo.org/413791#c0 - scheme48vm-prelude (for tests) https://bugs.gentoo.org/299414#c2 Closes: https://bugs.gentoo.org/299414 Closes: https://bugs.gentoo.org/413791 Closes: https://bugs.gentoo.org/589122 Closes: https://bugs.gentoo.org/710570 Closes: https://bugs.gentoo.org/722442 Closes: https://bugs.gentoo.org/830282 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-shells/scsh/files')
-rw-r--r--app-shells/scsh/files/0.6.7-Makefile.in-AR.patch26
-rw-r--r--app-shells/scsh/files/0.6.7-scheme48vm-prelude.h-SMALL_MULTIPLY.patch11
2 files changed, 37 insertions, 0 deletions
diff --git a/app-shells/scsh/files/0.6.7-Makefile.in-AR.patch b/app-shells/scsh/files/0.6.7-Makefile.in-AR.patch
new file mode 100644
index 000000000000..b5dfea96b998
--- /dev/null
+++ b/app-shells/scsh/files/0.6.7-Makefile.in-AR.patch
@@ -0,0 +1,26 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -259,12 +259,12 @@ $(VM): c/main.o $(OBJS) $(UNIX_OBJS) $(LIBOBJS) $(EXTERNAL_OBJECTS)
+ $(LIBCIG): c/main.o $(OBJS)
+ # $(CC) -r -o $@ main.o $(OBJS)
+ $(RM) $@
+- $(AR) $@ c/main.o $(OBJS)
++ $(AR) qc $@ c/main.o $(OBJS)
+ $(RANLIB) $@
+
+ $(LIBSCSHVM): c/smain.o $(OBJS)
+ $(RM) $@
+- $(AR) $@ c/smain.o $(OBJS)
++ $(AR) qc $@ c/smain.o $(OBJS)
+ $(RANLIB) $@
+
+ $(LIBSCSH): $(OBJS) $(UNIX_OBJS) $(LIBOBJS) $(EXTERNAL_OBJECTS)
+@@ -274,7 +274,7 @@ $(LIBSCSH): $(OBJS) $(UNIX_OBJS) $(LIBOBJS) $(EXTERNAL_OBJECTS)
+ $(EXTERNAL_INITIALIZERS) && \
+ $(CC) -c $(CFLAGS) -o /tmp/s48_external_$$$$.o \
+ /tmp/s48_external_$$$$.c && \
+- $(AR) $@ $(OBJS) $(UNIX_OBJS) $(LIBOBJS) $(EXTERNAL_OBJECTS) \
++ $(AR) qc $@ $(OBJS) $(UNIX_OBJS) $(LIBOBJS) $(EXTERNAL_OBJECTS) \
+ /tmp/s48_external_$$$$.o && \
+ $(RANLIB) $@ && \
+ rm -f /tmp/s48_external_$$$$.c /tmp/s48_external_$$$$.o
diff --git a/app-shells/scsh/files/0.6.7-scheme48vm-prelude.h-SMALL_MULTIPLY.patch b/app-shells/scsh/files/0.6.7-scheme48vm-prelude.h-SMALL_MULTIPLY.patch
new file mode 100644
index 000000000000..98c904a67e9f
--- /dev/null
+++ b/app-shells/scsh/files/0.6.7-scheme48vm-prelude.h-SMALL_MULTIPLY.patch
@@ -0,0 +1,11 @@
+--- a/c/scheme48vm-prelude.h
++++ b/c/scheme48vm-prelude.h
+@@ -5,7 +5,7 @@
+ #include "c-mods.h"
+ #include "write-barrier.h"
+
+-#define SMALL_MULTIPLY(x,y) ((x) * (y))
++#define SMALL_MULTIPLY(x,y) ((long)((unsigned long)(x) * (unsigned long)(y)))
+
+ #define NO_ERRORS 0 /* extension to errno.h */
+