summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-04-27 14:29:33 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-27 14:40:12 +0300
commit6821dfcf9d514b53b7ec1e28d26a8ba0469d816d (patch)
tree37326d9aff9b0535c0537d97d7a911f02e675bf9 /app-shells/dsh
parentapp-i18n/transifex-client: remove 1.6.10 and 1.6.5 (diff)
downloadgentoo-6821dfcf9d514b53b7ec1e28d26a8ba0469d816d.tar.gz
gentoo-6821dfcf9d514b53b7ec1e28d26a8ba0469d816d.tar.bz2
gentoo-6821dfcf9d514b53b7ec1e28d26a8ba0469d816d.zip
app-shells/dsh: EAPI=8
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-shells/dsh')
-rw-r--r--app-shells/dsh/dsh-0.25.10-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-shells/dsh/dsh-0.25.10-r2.ebuild b/app-shells/dsh/dsh-0.25.10-r2.ebuild
new file mode 100644
index 000000000000..40cc257b9efd
--- /dev/null
+++ b/app-shells/dsh/dsh-0.25.10-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Distributed Shell"
+HOMEPAGE="http://www.netfort.gr.jp/~dancer/software/dsh.html.en"
+SRC_URI="http://www.netfort.gr.jp/~dancer/software/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="nls"
+
+DEPEND="dev-libs/libdshconfig"
+RDEPEND="${DEPEND}
+ virtual/ssh
+"
+
+src_configure() {
+ local myeconfargs=(
+ --sysconfdir="${EPREFIX}"/etc/dsh
+ $(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ dodir /etc/dsh/group
+}