summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-16 02:00:33 +0000
committerSam James <sam@gentoo.org>2024-01-16 02:00:44 +0000
commitf7b2d17676704b9192030f968cf18cf1a0969a41 (patch)
treec158bafb21ccfe26378be6c7e61cc751c3cb7eb8 /app-portage
parentnet-vpn/tor: Stabilize 0.4.8.10 arm64, #922191 (diff)
downloadgentoo-f7b2d17676704b9192030f968cf18cf1a0969a41.tar.gz
gentoo-f7b2d17676704b9192030f968cf18cf1a0969a41.tar.bz2
gentoo-f7b2d17676704b9192030f968cf18cf1a0969a41.zip
app-portage/elt-patches: add 20240116
Eli Schwartz (2): werror patch: add a variant that works on debian-built dists color-record patch: add a variant that works on debian-built dists Sam James (8): patches: color-record: add upstream link/references patches: darwin20-conf: add upstream references patches: sed-quote: add new patch patches: cxx-pthread: add another upstream reference patches: fuse-ld: add upstream commit link patches: fsanitize: add upstream commit link patches: specs: add upstream commit link Makefile: add trivial check target Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/elt-patches/Manifest1
-rw-r--r--app-portage/elt-patches/elt-patches-20240116.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-portage/elt-patches/Manifest b/app-portage/elt-patches/Manifest
index 1807e6f3bad9..a704939b64d9 100644
--- a/app-portage/elt-patches/Manifest
+++ b/app-portage/elt-patches/Manifest
@@ -1,3 +1,4 @@
DIST elt-patches-20221210.tar.xz 42080 BLAKE2B abcdae6dedac89bd913d6809d335c13cd59b675c4b68198925bf758013e988a9bf82e9f6ccc3a70ac1c49775bb7579addda6c0bb7ea4ceea3c4b8e4acf0d65ea SHA512 3dad3c0be8d69de731bb10d5a6007539c2966f8a370a3dee27faf9655a38e39f272a9059cd98c8b6f32c2495143667f8b28a6a3425f22c0c5421f3969b417cf7
DIST elt-patches-20231228.tar.xz 42512 BLAKE2B 00d9e9ee06da0c6d218c3af79aeb171e78aee75a2e2d586746ecc10c1e0083b317e3c5f27c923f982557e075e39210775203d25c162e34b1698542a6c1d8c1c1 SHA512 e0278fe7776dfcb6e7e869da95dbb9a65b78efc08298a7c03c16953c0f1fcff34e0ef6533dbb7fd3c60297ed85c20eb0ca89a01d74d2f1e9c6f723341c867108
DIST elt-patches-20240109.tar.xz 42944 BLAKE2B 41df6a1c4f7a8f84986dcb5d31118173907ac9a5373aa663b3a7f40e3143063be0658bd9184086f04a5b81dea455e1a2f5fe6d39d02186891242b6cb9c2fcb8d SHA512 9f8ceb6da0b3bc741fc255ced2f48cef6f088d115ce667930897c2bd81c9491acbb30fd23348701e06467f09fa628e1a166c9df3d7331f3201ff3f2305529750
+DIST elt-patches-20240116.tar.xz 44400 BLAKE2B 0e664bf02180c2d0a5813f25a7661064f6612b71ab4743041a87579bf4fc2af276b2d653cbf75fe412364c2eb0a38dad744cc1eaa1159837239b0b9bbd122c5c SHA512 b014bebf918bb3debb5f38297caa0e250b426bdabfbc3c3e7ae44c1f5cda0d63ae1c0d82c12710a966a615947a5ad823a6e06c2ca485b987a74065dde16216bb
diff --git a/app-portage/elt-patches/elt-patches-20240116.ebuild b/app-portage/elt-patches/elt-patches-20240116.ebuild
new file mode 100644
index 000000000000..29410c13f990
--- /dev/null
+++ b/app-portage/elt-patches/elt-patches-20240116.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Collection of patches for libtool.eclass"
+HOMEPAGE="https://gitweb.gentoo.org/proj/elt-patches.git/"
+
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="
+ https://anongit.gentoo.org/git/proj/elt-patches.git
+ https://github.com/gentoo/elt-patches
+ "
+ inherit git-r3
+else
+ SRC_URI="
+ https://dev.gentoo.org/~grobian/distfiles/${P}.tar.xz
+ https://dev.gentoo.org/~vapier/dist/${P}.tar.xz
+ https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz
+ "
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~arm64-linux ~ppc64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+# The 'check' target currently wants network access to fetch libtool tarballs.
+RESTRICT="test"
+
+RDEPEND="sys-apps/gentoo-functions"
+BDEPEND="app-arch/xz-utils"
+
+src_compile() {
+ emake rootprefix="${EPREFIX}" libdirname="$(get_libdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" rootprefix="${EPREFIX}" install
+}