summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-01-20 19:55:50 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-01-20 21:45:12 +0100
commita5d0528c073bcf7c9668da7a1320f02fbdf3ca22 (patch)
treeea2e4348d7f1e7680687b3a8a930a3db07009dab /app-portage
parentapp-portage/elsw: tweaks; py 3.12; (diff)
downloadgentoo-a5d0528c073bcf7c9668da7a1320f02fbdf3ca22.tar.gz
gentoo-a5d0528c073bcf7c9668da7a1320f02fbdf3ca22.tar.bz2
gentoo-a5d0528c073bcf7c9668da7a1320f02fbdf3ca22.zip
app-portage/elsw: bump to 1.0.0
Bug: https://bugs.gentoo.org/894072 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/elsw/Manifest1
-rw-r--r--app-portage/elsw/elsw-1.0.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-portage/elsw/Manifest b/app-portage/elsw/Manifest
index aabbe62737bd..b924bb9e7892 100644
--- a/app-portage/elsw/Manifest
+++ b/app-portage/elsw/Manifest
@@ -1 +1,2 @@
DIST elsw-0.0.0.tar.gz 9857 BLAKE2B 8948b41bd163c393c735f08e94440905cca93078d8eefbb7b7136542a54a3139baaa4b40725667239fd249d9f569ececaf13631162502e3f58e5b288fdf1ae4f SHA512 9e0323ebdc01e6e2af2e021f2bfae2f977567697600167860de7a95d8c80e3119214524a6514114747bdebd269bf68d14f2e0369765d7fea62ae0adaf060e94c
+DIST elsw-1.0.0.tar.gz 9793 BLAKE2B 63e61eebda9fde9d6f1eeabca917038308fc4c91464424cca167ce37c3c4beb6c2eb2f61673ddc1519acf38820ec4ad44b31d3246727a4d039b958e5d04222ee SHA512 a85a0b76b74335f2107e78a9e70f8f07a8af3543a021f3b1b9c63e64f7884888b43dbe387f6be12ee15dfa58a25102d1c3c63945d5cace3cdc8a7c612b65fc60
diff --git a/app-portage/elsw/elsw-1.0.0.ebuild b/app-portage/elsw/elsw-1.0.0.ebuild
new file mode 100644
index 000000000000..f476f0d0e3b2
--- /dev/null
+++ b/app-portage/elsw/elsw-1.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tool providing a nice way to view the Portage world file"
+HOMEPAGE="https://gitlab.com/xgqt/python-elsw/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.com/xgqt/python-${PN}.git"
+else
+ inherit pypi
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ sys-apps/portage[${PYTHON_USEDEP}]
+"
+
+DOCS=( README.md )